Models disappearing from inventory (Website and Studio)

Ever since this bug got patched, I have had issues getting my models to show up in both the website’s my creation category and in studio.

Details: What this has meant for me is that for any model uploaded before 4/11/2020 will not show up in My Creations on the website, or in My Models in the toolbox in studio, or in the asset upload page in studio (see screenshot attached). All of these items will show up if you go into library and search for models made by my username, as well as in my inventory. Occasionally, it has also meant that any model uploaded period will not load on any of the screens mentioned, although i’ve only had this happen twice and both times relogging fixed it.

Additionally, when I get to the location in “Models” in My Creations on the website where my old models would normally be, it lets me press “More models” infinitely and refuses to load any models uploaded before the same 4/11/2020 date. Being unable to access my models is a problem for me because I have frequently worked with admin commands, and being unable to edit those modules means having to reupload my work.

Where it happens: This issue happens for all models uploaded before 4/11 on the screens mentioned in details. All models uploaded after 4/11/2020 seem unaffected. 4/11/2020 might not be the day the issue started, however it was the first time I was able to upload a model and have it show up again in studio or my creations. All models, with or without this issue, still load and work with :LoadAsset(), as well as with require() if they’re a module.

In studio, some models will show up when searched in the toolbox. Models such as this will show up, while models such as this this or this will not show up no matter what I search. The vast majority of my models were things that I used to use for the same purpose that packages now are – to store and load code outside of a game to load later. A lot of these models are no longer in use. All my onsale models seem to show up when searched. For the offsale models, this means I need to use :LoadAsset() to even read what I have uploaded.

When it happens: This issue happens whenever I load up any of the pages mentioned. This is a problem for me because it means I also can’t overwrite old assets now.

Reproduction: Unfortunately, I couldn’t get the issue to reproduce on any other accounts of mine, even with the same copies of studio. On all three devices I tested, I was on windows 10, and tried chrome, firefox, and edge to launch studio. I question if its an account issue, or a bug with something i uploaded previously, because it seems account or inventory specific. I have some models from way back in 2018 that I wonder if are the cause of the problem. I uploaded things such as the lighting service, and I think a starterguis instance, because I wanted to experiment with what happened if I tried using loadasset on them. I put one of those models onsale, and noticed that the library never loads that specific model as of a few minutes after putting it onsale (test - Roblox). All models show up fine if I put them onsale in the library.

So, to summarize:
-This bug causes old models to never load in “My models” in creations on the website, the asset upload screen in studio, or the toolbox in studio.
-This bug happens 100% of the time, only on this account as far as I can tell, and on multiple devices.
-No matter how many new models I upload, no more models after “brick” will disappear, nor will ones from before “brick” reappear
-Occasionally, all of my models will disappear, instead of just those from before 4/11/2020. I believe that this issue may be independent.

-Lets say that I wanted to update this model of mine, called lock, which is a script for a basic lock/unlock tool. First, I use the following line of code to load it into the workspace to access it, since it won’t easily show up in my models:
From there, I have the model in the workspace and can edit the model however I want to. However, if I go to my save to roblox page, I can’t scroll down far enough for it to show up when I want to overwrite it. No models after a certain point will load. I can reupload the model and it will work just fine, however I have a ton of models and it would be an absolute pain to reupload each one.

Searching for models in the toolbox allows certain models to show up again. This might provide some insight as to the cause of the issue, but doesn’t solve the issue because I still can’t publish anything to these models.


I’ve experienced similar issues, I hope this gets fixed in the future. Sometimes I am not able to load in models that I have in my studio. It got annoying so I reloaded studio and then it worked. The models still do this issue.

1 Like

This happened to me, I wasn’t able to load in a model I had. The model says that I own it but when I look in “My Models” in Studio, it’s no where to be found. It’s good to know I’m not the only one experiencing this.

Thanks for reporting this, we are looking into it and will reply here.


Help us !!!
the toolbox is not showing everything in my inventory

Normal inventory should look like this:

The image below is so strange

I tried to search and import a gun I usually use in my inventory but there are no results


that’s happening to me too right now. i’m unable to continue developing because of it


Hey @BEARboo63 and @ROSKAA123 (and anyone else from 2 years ago), we believe we’ve fixed this for models and plugins. Can you check that it’s fixed and let us know?

It is fixed ^_^!!! thanks a lot

1 Like

Hi riddle,
I am still having this issue in 2 places: my models in the toolbox in studio, and “Models” under creations on the website. In both places, I am still unable to see my models created prior to April 2020 in the same way that I wasn’t able to when I initially made this post. However, the part of this bug on the asset configuration page did eventually get fixed for me, I think a few months after FriendlyAdder said he would look into this. I think I am understanding your question correctly?

1 Like

Hey @TJW123456, sorry to hear that it’s still happening. Can you send me (or DM if you’d prefer) the asset ID’s that aren’t showing in “My Models”? Also, if you created them, are they showing under “Creations”?