Moving part in animation editor causes entire rig to move around it

When I try to move a part in the animation editor, instead of that part moving, the whole rig moves/rotates around it.

As it stands currently, the whole rig is unanchored. I’ve tried anchoring the root part and then unanchoring everything else, but that just stops me from moving the parts period.

The following video shows what I mean.

The gun is a direct appendix of the camera part (the red part in the video), which is also the root part of the whole rig. These are the properties of the Motor6D that connects the two. I’ve tried setting Part0 to Union and Part1 to CameraPart, but that doesn’t seem to fix it either, and instead causes other problems.

I’m aware that similar topics to this have been made, but they are very old, and after almost a year of bumps, no one could answer the question. I’ve had this problem when rigging and animating viewmodels on at least two separate occasions now, and it seems to occur at random.


Alright, nevermind, case closed; I was wrong about my original judgment. Turns out I had other parts anchored and didn’t think to check for them.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.