Multiple Roblox Services Failing

Reproduction Steps
Call different functions from different services. (TeleportService, MarketplaceService, ChatService, etc)

Expected Behavior
Services to work properly. Less than 30 chars.

Actual Behavior

Services aren’t working causing the game to be unplayable.

Issue Area: Engine
Issue Type: Other
Impact: Very High
Frequency: Constantly
Date First Experienced: 2022-02-12 09:02:00 (-05:00)
Date Last Experienced: 2022-02-12 00:02:00 (-05:00)


Same and some random studio errors where the place name doesn’t load correctly (apart of this issue)


Thanks for the report, our teams were alerted to a platform issue a little over an hour ago and have been investigating.


I’m getting strange errors in my output.

+1 on this issue, I was planning to release a big update today but roblox has been having issues with this.

Yup, my studio is completely unusable at the moment @_@

1 Like

bru, it worked for me for a sec but then doesn’t work again

These services seem to be having downgraded performances.

Getting this error as well

This has also been happening to me.

add me in too it hasn’t been working for 2 and a half hours

1 Like

Teleport services not working!!!

I dont think we should be tampering with studio right now, it works for me but i fear that i might mess something up that would cause the place file to get corrupted, or worse.

It works after a while, then doesn’t work after I stop in test mode. Very odd.

I’m unable to create a new place without crashing studio, I also share similar errors in the output of games that I’ve already published. I’m guessing they’re both linked.

1 Like

it works for me, only problem is that some scripts will run after the shutdown deadline, ending with me having to wait 2 minutes or more for the test mode to properly shut down, pretty wack.

1 Like

MarketplaceService:getProductInfo() failed because HTTP 502 (Bad Gateway)

MarketplaceService:getProductInfo() failed because HTTP 503 (Service Unavailable) 


I am also getting issues with the teleportservice for teleports within my MMO which is heavily reliant on teleportation between different servers (which act as different worlds). Players have been getting this error after teleporting and then getting immediately booted from the game:

Here’s what the console says, as far as I’m concerned the verification is broken:
I can verify that this definitely is not an illegal destination, and everything has worked fine for months until now.


Following up, this issue was resolved on Saturday evening!

Please file a new bug report if the issue occurs again.


This topic was automatically closed after 2 days. New replies are no longer allowed.