Mute button does not respect losing/regaining focus

The “Mute” button under the Test tab in Studio during Solo or Play mode gets overridden by losing or regaining focus of Studio (differs based on the “Only Play Audio from Window in Focus” setting).

If the “Only Play Audio from Window in Focus” is on then the Mute button automatically unmutes when focus is regained to Studio. If the setting is off, sound is unmuted immediately when Studio loses focus. Both behaviors seem to be wrong.

Instead, that property should not influence the Mute button. If the player uses the Mute button, it should override that setting. If I click Mute, sound should stay muted whether or not I lose or regain focus of Studio.

Here’s a quick clip of this behavior with the “Only Play Audio from Window in Focus” on. You might need to use your audio to hear the problem too:


  1. In Studio, start playing in Solo or Run mode and have a song playing in the game.
  2. In the Test tab, click Mute.
  3. Focus on a window other than Studio.
  4. Refocus Studio.
  5. Observe that Mute is no longer working.

When “Only Play Audio from Window in Focus” is on, this failure will happen on step 3. When off, the failure will happen at step 4.

I don’t know if this started recently or has existed. First observed it today.

Studio version: 0.461.0.416397
OS: Windows 10


This has been annoying me a lot recently, I’ve been working often while in a voice call and my game has ambient sounds that can drown out who I’m talking to.


Thanks for the feed back! I have created a bug ticket for it.


This has been a issue as long as I remember. That is why I created a little snippet of code that just turns all the sound emitters off, when I’m testing in Studio.

1 Like

Hello. Due to the nature of how this feature was implemented, that being that the user would always want to hear sounds from the currently focused view, this is currently functioning as intended. This decision may be revisited in the future however.


I do not think this is the correct behavior. The “mute” should function as an override in all cases, regardless of focus.


Then what is the point of a mute button? It doesn’t work properly.


The notion that this is functioning as intended is stupid. No program on earth with mute implemented correctly will unmute itself if you tab out and then back in.

The expected behavior is that if the user mutes a Studio instance, it will forever remain muted until the user unmutes it. It seems the bug is that Studio needs to split the user mute setting from some internal mute setting used to control which Studio instance is playing audio.

Right now, if I am in e.g. a voice call and I mute Studio, if I click out into my browser to read documentation or check out something they linked, and then back into the same single instance of Studio, it will unmute itself and drown out the person I’m talking to and/or deafen me depending on the volume level I have set, which is usually pretty high because I use speakers when I’m not in a call.


Thanks all for bringing this to our attention! The behavior of the mute button in Studio should now be fixed to respect losing/regaining focus.


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.