My Game Name is not Updating, please help

I have tried to change my games name but nothing is working. The link changes, the place and game in studio will change, but the name on the game page does not. Here is the link to the game: Cloud Simulator(Performace Update Expect Bugs!!!) - Roblox I do not know what has caused it but here is the information I have.

It is a game created by me not a group
The name it is stuck on is 49 characters long
It started when I changed it to this name
People have told me to double click the save button or just wait a while, neither solutions have worked.
Saving it in Studio VS Saving it on the website both have no effect.
I have tried changing both th game name and place name(configure game and configure place)

If you need any other info just comment on this post.
Any Help is appreciated!!!


I think that you’re able to change the name by configuring the game and configuring the place. I’ve had this problem before, and my solution was changing the name for both the game and the place, so try that.


I have already tried that. Any other ideas?

Is it related to this issue?

No it does not say anything about the name being inappropriate.

i guess you could try Publishing

I have this exact issue.
I even tried making a post on it but it got taken down.

I contacted roblox support but im getting the typical response of trying basic things like check your browser or firewall.

this is a serious problem, im gonna have to move my games to a new place just to be able to change the title.

several other people are having this problem, why is roblox not addressing this?


I don’t understand why this hasn’t been adressed yet. Its a serious problem and it needs to get fixed.


I have already tried that. I have tried almost everything I can think of

1 Like

How about logging in as another account? It actually worked for me and the name changed.

I asked a lot of my friends and they said the name wasnt changed i can try though.

Okay, make sure to open roblox studio, press game settings then press localization and put English for Source Language. This should work!


Saving the game only does so to your computer or device. You must publish the game. I had this same issue. You have to publish it.

When I say save I mean from the game settings and place settings. And yes I have tried publishing it.

Trying it right now, fingers crossed it works.

OMG IT WORKED, Thank you so much!

Thanks! I was having the same issue as well!

1 Like

I’m also indeed having this issue also for some odd reason it does not update the game name.

Another solution I want to add, go to views => asset manager => places and make sure to update the game name there (this controls the one in the loading screen and your roblox studio)