My game works but my friend's game doesn't


First of all… I am not sure, which gategory this problem belongs and now here’s the problem:
I shared my game with my friend who just downloaded roblox studio. I used “collaborate” and gave my friend access to my game and he can now edit in my game. We both tested the game by pressing “Play” button in studio. When I joined, game worked as I wanted. Gui’s are visible, codes are working and so on. However, when my joined, he was stucking in my created loading screen which has image of my logo, loading bar which loads all values that you need in the game. Loading screen should disappear and destroy itself when all values are loaded. Well… because loading screen was stuck, I disabled it and after that, all my friend’s imagebuttons didn’t do anything. They should make Gui’s visible. We both don’t know, why this happens. Can you help us??

My friend’s view:

and mine view:

Here is loading screen’s code:

local Main =
Main.Visible = true
script.Parent.skip.Visible = false
script.Parent.loadmore.Visible = false

local loaded = game.Players.LocalPlayer:WaitForChild("Load"):FindFirstChild("Loaded")
local ReplicatedFirst = game:GetService("ReplicatedFirst")
local ContentProvider = game:GetService("ContentProvider")
local TweenService = game:GetService("TweenService")
local Player = game:GetService("Players").LocalPlayer
local lll ="IntValue", Player:WaitForChild("Load"))

local Holder = Main:WaitForChild("bar")
local CoreGui = game:GetService("StarterGui") --the service

CoreGui:SetCoreGuiEnabled(Enum.CoreGuiType.Health, false)
CoreGui:SetCoreGuiEnabled(Enum.CoreGuiType.Backpack, false)
CoreGui:SetCoreGuiEnabled(Enum.CoreGuiType.PlayerList, false)
CoreGui:SetCoreGuiEnabled(Enum.CoreGuiType.Chat, false)
CoreGui:SetCoreGuiEnabled(Enum.CoreGuiType.EmotesMenu, false)
CoreGui:SetCoreGuiEnabled(Enum.CoreGuiType.All, false)

local function fadeOutBackgroundAndElements()
	CoreGui:SetCoreGuiEnabled(Enum.CoreGuiType.Health, true)
	CoreGui:SetCoreGuiEnabled(Enum.CoreGuiType.Backpack, true)
	CoreGui:SetCoreGuiEnabled(Enum.CoreGuiType.PlayerList, true)
	CoreGui:SetCoreGuiEnabled(Enum.CoreGuiType.Chat, true)
	CoreGui:SetCoreGuiEnabled(Enum.CoreGuiType.EmotesMenu, true)
	CoreGui:SetCoreGuiEnabled(Enum.CoreGuiType.All, true)
	local OutTI =, Enum.EasingStyle.Quint)
	local ImageLabel = Main:FindFirstChild("ImageLabel")
	local SkipButton = script.Parent:FindFirstChild("skip")
	local morel = script.Parent:FindFirstChild("loadmore")

	if morel then
		TweenService:Create(morel, OutTI, {Transparency = 1}):Play()
	if ImageLabel then
		TweenService:Create(ImageLabel, OutTI, {ImageTransparency = 1}):Play()

	if SkipButton then
		TweenService:Create(SkipButton, OutTI, {TextTransparency = 1}):Play()

	TweenService:Create(Main, OutTI, {ImageTransparency = 1}):Play()

	for i, ui in pairs(Main:GetChildren()) do
		if ui.ClassName == "Frame" then
			TweenService:Create(ui, OutTI, {BackgroundTransparency = 1}):Play()
			TweenService:Create(ui.filler, OutTI, {BackgroundTransparency = 1}):Play()
			TweenService:Create(ui.loadingb, OutTI, {TextTransparency = 1}):Play()
		elseif ui.ClassName == "TextLabel" then
			TweenService:Create(ui, OutTI, {TextTransparency = 1}):Play()

		if ui:FindFirstChildWhichIsA("UIStroke") then
			local Stroke = ui:FindFirstChildWhichIsA("UIStroke")
			TweenService:Create(Stroke, OutTI, {Transparency = 1}):Play()


	local loadingProgress = (loaded.Value / 25) * 100
	Holder.loadingb.Text = "Loading Values.. (" .. loaded.Value .. "/25)"
	TweenService:Create(Holder.filler,, Enum.EasingStyle.Quint, Enum.EasingDirection.Out), {Size = UDim2.fromScale(loadingProgress / 100, 1)}):Play()

	-- Tarkista, onko lataus valmis
	if loaded.Value == 25 then
		wait(3) -- Odota hetki
		fadeOutBackgroundAndElements() -- Kutsu funktiota, joka piilottaa elementit
		Main.Parent = game.ReplicatedStorage



while true do
	if lll.Value == 1 then
		script.Parent.Enabled = false

And here is from explorer:

1 Like

I have had the same issue with my friends regarding animations. From what I understand is that Roblox doesn’t necassarly work in Team Create if someone scripts a part, the other one will not get it to properly function. Best thing is to test on the roblox client (Live game) or save any recent changes made

1 Like

Make sure you’ve committed the script. Go to view > drafts and check for uncommitted scripts.

Sorry for very late answer. I enabled dratfs but still it doesn’t work. What should I do now?


Try saving the changes first and testing the game via Run and not Team Test. As @CE0_OfTrolling said, it’s most likely due to script being uncommited.
As a last resort, you can try testing the game in the Roblox app and not in Studio.

1 Like

I commit every script by doing this:

  1. After I made changes in the script, I commit it.

  2. After that it disappears:


But still, when my friend presses “Play”, almost every script does not work. Some work, but every other script doesn’t:
My friend presses this button.

Can I get help please??? I need it right now.

Well… this is weird.

One GUI appears correctly but other doesn’t. Why some works and some doesn’t? This is weird. In real game (Roblox server) it worked before but in studio my test play works normally but my friend’s test play does not work as it should.

hey. Please help me. No one has helped since the last time 9 days ago. Please. I need help.

try put the loading screen onto a regular script (which runs on the server) or iterate all players gui and update them with the loading screen.

Loading screen is not the only problem, almost every single Gui is not working on my friend’s test play. Loading screen is the example. It’ll be mess to change every local script into server script and it will be almost impossible to do that.

okay, mabye try move the function where it updates the gui to a server script then in the localscript it fires a event to get it to update the ui.

1 Like

I just remembered that even the daily reward system is not working. Daily reward system code starts from server script and then fires client event but because it’s not working, it means that even server scripts may not work. This it pretty weird because my game works how it should and my friend’s game scripts doesn’t work.

woah. 10 days and no one hasn’t answered on my problem yet. I need solution because we can then make our game without any problems.

Have you tried to Publish all recent changes instead of regular saving?

But we are making update. That’s why we cannot publish it. The update is not ready yet.

Just make two seperate places, one is indev and one is the actual place

You mean that I copy everything, make new datastores and when we are ready, we copy everything into the real one? But there has to be a better way to do it because others can make games together without this problem that I am facing right now.

So what you do is:
Create a baseplate and rename it to something like [INDEV] Game Name
You now go into your game and find “Publish To Roblox as…” (or just press Alt+Shift+P)
Now you find the indev and once you find the indev you click on it and press Overwrite
Now everything should be in the INDEV but everything stays the same in the place
Once you done that, everything in the Indev can be now modified and Published without the public noticing it
And when you need to update it, you just make the same steps but now with the Indev

So when you are in the Indev, when something is not working for your teammate, press “Publish to Roblox” and see if it works or nah

1 Like