My Lua syntax error checker has disappeared

I remember that sometimes the syntax check likes to disappear when there’s just a single error somewhere, but I don’t seem to notice it to highlight anything anymore at all. How do I enable it or find errors that are highlighted?

Also I tried to reinstall studio and it didn’t help.

13 Likes

Can confirm it’s not showing up at all, regardless of settings

1 Like

Been noticing this since yesterday, I never knew how much I relied on it until it was gone :frowning:

1 Like

Do you have repro steps for this? My script editor still seems to work fine.

1 Like

For me this is happening in a fresh place.
image.png

Maybe my custom colours are breaking something :slight_frown:

1 Like

What are your custom colors set to? I’ll try it here and see if that breaks it.

1 Like

I went back to the defaults and it had no effect

image.png

1 Like

@Silent137 I’m running on Win 8.1 btw, default editor colors.

Are all of your settings still default as well?

I have the same issue on Win10 Pro with all settings default, I don’t get any feedback from intellisense anymore. I’m reproducing it by opening a new place in Studio, inserting a Script into workspace, and then pasting @MasterDaniel’s code into it. Also does not give any intellisense during Run mode or in Test Client/Server. Studio version: 0.281.0.108659, anything else you need to know?

I’m also Win10 Pro on the same build.

Just to be sure, this is enabled for me. I toggled it off and back on and no difference. Although I am still getting autocomplete suggestions.
image.png

Ah, it looks like one of our new features broke the coloring. It’s still catching errors at least (as seen in Script Analysis). I’ve added it to our bug list, we’ll try to get that fixed up.

8 Likes

I made a thread about this a while ago too: Errors inside scripts not showing up

This should be fixed now in the latest version

3 Likes