My mesh is "see-through"

I tried what you were talking about and unchecking the ‘Inside’ box but It didn’t work.

I never had this issue with 3DS Max, and it happens all the time with Blender.

3DS Max is free, and a much better and more capable tool.

3DS Max is neither free, nor “more capable” than blender pertaining to Roblox development. If by “free” you mean the educational license, you should be aware that it’s against autodesk’s terms to use for anything outside of personal projects, meaning it’s illegal to use for Roblox development unless your projects are never going public


Were you in edit mode? Did you have all faces selected? Did you view the normal direction in Blender to even just confirm that they’re facing the right way before importing it into Roblox? Something isn’t being done properly

1 Like

Extremely inefficient? I’d beg to differ. Even if it doubles your polygon count… No car is paper.

This is actually correct, it’s just lacking faces on the top and the bottom


It is much more capable. You’re wrong about the license as well. It is intended for educational uses, which Roblox is included in. Making a Roblox game is indeed very educational, depending on the user. For someone who’s learning to model, script, etc, it works great. If you make Roblox games for a living, you can’t use the educational license.

Software and cloud-based services subject to an Educational license may be used solely for purposes directly related to learning, training, research or development. The software and cloud-based services cannot be used for commercial, professional, or any other for-profit purposes.

Not a lawyer, but my person opinion is that you can earn money off your game and it can still be an educational project rather than a commercial one. Afaik, you can’t refuse to receive Premium payouts/

The inability to refuse premium payouts is exactly the reason why it’s illegal to use for Roblox development period. As long as you are making any robux off of your game, it’s in violation of autodesk’s terms; your personal definition of “educational purposes” has no bearing on whether or not you’re allowed to use the software for roblox development, and the fact that you’re making this argument leads me to believe that you are potentially in violation of this yourself.

You’re right—you’re not a lawyer, because if you were, you would know the delineation between personal and commercial projects. If you make even a cent, it’s a commercial project.


Solidifying adds even more than double the faces to your model in order to fix a problem that can be directly addressed without needing to add the extra faces.

You just answered your own question of why it’s inefficient: because it doubles the polygon count. There is a way to fix inverted normals without solidifying and takes only a few seconds to do; why would anyone opt to solidify with this option readily available that doesn’t affect the poly count or introduce complicated collision calculations into your game?


I don’t think it’s that deep man. I’m not a blender professional but from personal experience, Using the modifier doesn’t really impact gameplay. That’s all i gotta say.

It’s that deep when you’re dealing with multiple models that have all been “fixed” by using a solidify modifier. It may very well not impact gameplay with builds that use meshparts sparingly, but it’s important to learn the best practices of modeling if a developer wants to be taken seriously in any major project. These things do add up when working with more complex builds and directly impact the performance of players

1 Like

You do you. I found no issue with the way i do thing’s but if that time ever comes, i’ll surely figure it out. Goodluck with future projects :+1:t2:

I’ve found an easier solution that has worked for me. In the properties of the object there should be an option called “Double Sided” make sure to check that box and it should fix all the problems.

1 Like

Please delete this addendum as it’s not a valid solution for your original question and actively harms new developers who are unfamiliar with what this property does

Yet it’s still the solution to fix the verteces doing those stuff, I know there is a far better way to do this which is just inverting the verts in blender, however it’s still a solution nonetheless

1 Like

Just because it’s possible to do doesn’t at all mean that you should and then mark your own uninformed fix as the solution. It’s bad advice no matter how you slice it

GhostRunner is right, the issue is caused by the mesh normals being flipped and turning on DoubleSided is NOT a solution, it looks fixed but it’s not. the mesh is corrupted and you should be fixing it, even if you don’t want to, at least unmark your answer so that other people aren’t mislead, this is terrible practice