Why Are The Faces Inverted?

I am making a tv for my future game. However, when I imported it, the faces were inverted.

I have noticed this appearing in Unity, and I just had to adjust some variables. How do I fix this? I don’t want to use double-sided because it causes lag if you have lots of faces.


Use the search feature please, this is by far the most common question on the forum -


try inverting normals maybe? idk im not professional idk what dat does even

This is a VERY common question on the forum and I see a lot of people ask this. Import your mesh into blender and then make sure to copy and paste all the sides not showing up and then flip them over so it’s double sided.

1 Like

i don’t think that makes it double sided. just flips the faces.

I’ve found an easier solution that has worked for me. In the properties of the mesh there should be an option called “Double Sided” make sure to check that box and it should fix all the problems.


PLEASE DO NOT USE THIS AS A FIX, it doubles your polycount and makes meshparts take up twice as much processing power than if you had just modeled it correctly in the first place. Double-sided should only be used in rare instances where it is necessary like foliage and signs.

1 Like

Solidify the mesh in blender
30 ._.

So what do we do instead of using double sided?

An alternative would be to go into blender:

Edit mode.

Under the MESH tab click: NORMALS, then click RECALCULATE OUTWARDS.

This points all the surfaces outwards thus eliminating the problem.

Remember to press A to select entire mesh before doing this otherwise it doesn’t do anything.

Oh ok thank you for the telling me.

1 Like