My Recent Uploaded Animations No Longer Work

As of an hour ago, I recently tried uploading an animation to my personal inventory but when I try to import it into my character through the animation editor, I get the warning “Animation was not imported. You do not have ownership of the animation with the selected id

I also can’t find the animation in my personal inventory.


After about 5+ hours :sad: and unable to work, I can now access the animations, unsure if this issue has been solved or if this is now the current standard for approving new animations.


Seems to be the current standard. They gotta pass moderation perhaps.


hope this isnt true… waiting hours just for one animation to be tested is absurd


seems to be the case, its been happening to me while ive been working on a little project that i was doing for fun.
it’s no longer fun. i should have been finished by now, but i’m waiting on roblox’s awful moderation system to accept animations that are literally not even 30 seconds long. this is unacceptable for a platform of roblox’s size and wouldn’t have been acceptable ever.


This is still occurring. I uploaded animations 10+ hours ago to my profile and they’re still not in my inventory.

The animations I’ve created appear in the Creator hub

But not in my actual Roblox inventory

The only workaround for this atm is to upload to a Roblox group that you own.

This also occurs with models (seems like animations take extra long though.)

Edit: @Rexinator2400 I wouldn’t mark this thread as solved as Roblox might believe this bug is resolved when it really isn’t.


Just unsolved it, it seems this issue is prevalent :face_with_head_bandage: so leaving this thread for reproduction steps

1 Like

This issue has been going on for nearly a week now and I am yet to hear a word from roblox regarding it

If they are aware, it means they’re probably working on it, issues like these just take time as this unexpectedly occurred from a new update overhaul.

1 Like

Just reported this bug to Roblox Support, hope they fix that… :pensive:

Yeah, when you upload an animation, it doesn’t even put it in your inventory.

This was actually entirely unrelated to moderation, it was just an internal operational issue.

It should be resolved now, sorry for the wait.


Glad to hear it, thanks for the update

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.