New 'LoadCharacterLayeredClothing' Cage mesh deformer causing packages to not function correctly

Reproduction Steps
Enabling this option with the aformentioned instructions listed in the post: 3D Layered Clothing is Now Available! causes packages to trigger the ‘Changed’ state, even if there’s no actual change to the package.

This causes packages to not work across places.

Repo:
Create a new layered clothing model in software (Eg: Blender) with the steps followed in the original post Cage Mesh Deformer - Studio Beta

Package a folder in studio containing an accessory version of this import using the Avatar Importer plugin under Rthro

Publish this package and copy it to another place with LoadCharacterLayeredClothing Enabled under StarterPlayer

NOTE: The actual mesh does NOT follow Rthro exactly, we’re using a custom rig, though for our purposes, the rig does work.

System: Intel(R) Pentium(R) CPU G4600 @ 3.60GHz, 8 GB, NVIDIA GeForce GTX 1050 Ti

The 3D Layered Clothing Beta Feature is Enabled

Expected Behavior
We expect that the package does not trigger ‘Changed’ within another place instance, so that we can keep all places up-to-date with this option enabled.

This causes issues with publishing and related functions

Actual Behavior
Within the place that you publish the package, it stays updated and is functioning correctly.
However, within another place instance, the ‘Changed’ bubble appears, preventing any form of publishing unless publishing the package in the offending place.

Enabling the option w/ an existing package with caged meshes contained (Not in the origin place in which the package was updated)

Placing a copy of the package into a new place with the option enabled, triggering the ‘Changed’ tag on the package

The offending items
image

Issue Area: Studio
Issue Type: Other
Impact: Moderate
Frequency: Constantly
Date First Experienced: 2021-10-20 00:10:00 (-07:00)
Date Last Experienced: 2021-11-05 00:11:00 (-07:00)
A private message is associated with this bug report

Thank you for your report ! We are already aware of this issue and we’ll follow up when we have an update for you.

2 Likes

Hi thanks for your report, I tried to repro on the lastest production (version 504) and can’t reproduce this issue. If this still happens to you, can you send a full video about all the steps you do after setting up the beta feature to when you meet this issue? Thank you very much!

Hey not sure if you saw my bug report, I reported the bug on 3D Layered Clothing is Now Available! here.