New Physics Stepping Method: Adaptive Timestepping

Lag as in game lag not computer wise

Keep in mind you don’t have to use adaptive physics step rates so your assertion that it will break a lot of games isn’t necessarily true.

Yes, I agree, GodSysAdmin, regardless of the Adaptive choice, the “Fill terrain with Air” feature should be fixed. As an alternative, you could use explosions to remove terrain (non-joint-breaking). It does push the character a little, but they seem to fall in the hole just fine. Maybe its the little push that helps the character fall. I use this technique (terrain explosions) in my game Growing Up (https://www.roblox.com/games/1182833048/Growing-Up) and I have never had the levitation problem you described. Its the Dream task at age18: Blast for Treasure. If you don’t have time to level up, you can watch this youtuber: (Growing Up Dream Update! | Roblox Growing Up - YouTube)

2 Likes

Uhh… My computer still lagging.

[color=“FF0000”]Important[/color]

The new physics stepping method crashes inverse kinematics
I had a three day row about how these crashes were completely ruining my ability to work, and then I had discovered this new beta feature was the culprit.

4 Likes

On release, will the criterion for this be well documented enough so that we’d be able to design our game such that we can keep as much of it in a frequency that we want?

2 Likes

This feature looks helpful, but what I’d really like to see is a reduction in the rate of physics related network traffic for parts that are distant from the client. I’m bottlenecking on physics server->client kB/s way before hitting a physics CPU bottleneck. I’ve had to move much of the game’s physics simulation to client-side CFraming to make the game playable.

Also, ideally the server wouldn’t need to send any data to the client for the case where the client can perfectly predict the next server->client update based on its own parallel physics simulation.

1 Like

I know this is a bit niche, but do you think we could get some sort of a sensitivity setting for the new PhysicsSteppingMethod?

1 Like

If you enable StreamingEnabled you can set the StreamingPauseMode to ClientPhysicsPause

1 Like

Yeah, this will definitely help with those who don’t have strong CPUs myself included. :sweat_smile:

1 Like

Nice nice I like the idea of having dynamically changing frequency based on client engine performance, adds more capability to the overall design of the game without having to worry about lower-end devices.

image

YES! FASTER SIMULATION FOR LOW INTENSITY. :grinning_face_with_smiling_eyes:

Is this change in relation to the new RunService event additions?
RunService.PostSimulation(double deltaTime)
RunService.PreAnimation(double deltaTime)
RunService.PreRender(double deltaTime)
RunService.PreSimulation(double deltaTime)

4 Likes

Was the beta feature disabled because I can no longer find it in studio?

1 Like

Seems like they turned the corresponding FFlag off, so yes, it seems to have been temporarily disabled. :confused:

1 Like

Yea I just saw that on the FFlag watcher. Hope it comes back soon

Thanks for everyone who were able to give us feedback! We decided to disable the beta feature until we rule out the reported bugs. Stay tuned!

6 Likes

Will it be able to prevent this?

My thing glitches into the ground when it’s not supposed to.

1 Like

It looks like this feature was disabled for now, so my Terrain-based physics bugs (the “phantom voxels” bug) is no longer manifesting. Thank you!!

Hopefully this issue (and a few other defects attributed to it in this thread) can be addressed before it is re-released. I look forward to getting these addressed so that we can use the Adaptive Timestepping improvements!

As a reminder, I have a read accessible demo Place in my post above which provides a Repro for this defect. It recreates the errors to show both parts and characters left floating in the air after terrain is removed. It also demonstrates missing terrain acting as obstacles in horizontal movement too (not just falling). My demo also includes a simple GUI to turn on/off different potential work arounds for the defects.

Update: After some multi-platform testing, it seems these phantom voxels were only happening on Macs or in games where there was a Mac present. I tested iPhone, XBOX, and PC and did not see the issues unless there was a Mac connected too. Maybe this has something to do with network ownership for physics… In any case, the problem is currently resolved since the feature is disabled.

1 Like

So, as of today, the defect has returned in the Player and is manifesting publicly. I assume Adaptive Physics Stepping has been re-enabled. The phantom terrain voxels are back and wreaking havoc with my games. It is also causing strange things in a few games I play. Curiously, it is not happening in Studio as of now-- I assume the relevant flag is disabled in Studio but enabled in the Player, or that there is code divergence based on commits here.

  1. I recommend this feature be turned off because it was not fixed yet.
  2. If it remains, perhaps Terrain manipulation should just be deprecated (most games use Parts anyway).

For example, if you use a rocket launcher to make an Explosion with Craters enabled, this will often remove some terrain voxels. But, on the Roblox Mac Desktop Client, this will lead to the player floating mid-air if they jump into the crater.

I reproduced this in 1 minute using the Team FFA/Arena Starter Place. (I simply had to edit the Rocket Launcher to enable Craters, and voila – I had phantom voxels).

I’ll file an official bug report now I guess…

Hey ScottSpiritWalker,

Thanks for the response and feedback. This defect went away a few weeks ago, but I noticed it had resurfaced today on the Mac Player client. The weirdness in removing Terrain continues for Mac users after a brief hiatus. Previously it affected the Player and Studio on the Mac, but currently it only impacts the Player now.

I viewed the video link you shared, and indeed it shows normal handling for physics when Terrain is removed. Thanks for sharing that.

I then played your Growing Up game and made it to the Dream task where you have the laser gun to remove Terrain. On my Mac, I observed the same physics defects that I described earlier, with floating in the air above removed Terrain. In your case, I believe you are using Explosions with Craters to remove terrain.

So this defect is affecting your game – I captured a video and uploaded it here:

I have not tested recently on iPhone, XBOX, or PC to see if this occurs, so it could be happening there too. If it is Mac only, I am not sure about the % of Users who have Macs.

By the way, I like your game – it’s fairly broad in capability and pretty cool! I mean Pets, NPCs, Tips, Quests, Vehicles, Dancing, etc. Cool stuff!

Hello! I’d like to activate this beta for my place.

Place Id: 6004108409

Direct Place URL: https://www.roblox.com/games/6004108409/