Not any client can reach ReplicatedStorage?

Hello. Today I had a very weird problem. Everything was fine. But for a reason that I don’t know, every client script gave the same warning: “xxx is not a child of ReplicatedStorage” Even default Roblox scripts did. I cannot use the chat.

Everything is fine in scripts. They were working well. I didn’t change anything but the problem came out.

An example Script(Client):

local rep = game:GetService("ReplicatedStorage") 
local remoteFunctions = rep:WaitForChild("RemoteFunctions") 
-- remoteFunctions is a folder

local items = remoteFunctions:WaitForChild("Tools"):InvokeServer() -- Tools is a RemoteFunction

And there is an example error:

as you can see, it cant reach remote events/functions things in ReplicatedStorage. Can someone help me with that? Did you experience this problem before?
Thanks for reading.

Odd. I think you may have misspelled your RemoteFunctions.

It’s a bug. It’s happening for everyone at the moment, I have just tried using it as a test and I got the same result as you did. Infinite yield possible on 'ReplicatedStorage:WaitForChild("test")

Hmm. So we will wait for Roblox to fix this?

Yes. I really hope they fix it soon!

1 Like