NPC sliding around even though hipheight is set above 0

As read above, this NPC here is shown to slide around when heading to way points when it hasn’t before. The hipheight is above 0. I’ve tried making every part massless and not massless, hasn’t seemed to help either way. Is there a fix?


oops, forgot the video.

Hey! There has been past topics on this and I think I could help. One user named ChefJustice had a good addressing a similar topic (NPC Humanoids Sliding like Crazy) stating
1) Create a generic R6/R15 rig and use this as your “base” rig. For this base rig, set the transparency of limbs to 1, remove face decals, etc. etc.
2) Weld your custom NPC rig to the HumanoidRootPart, positioning its offset from the HumanoidRootPart such that it appears to be standing on the ground. Your custom rig should be massless, CanCollide = false
3) Run all humanoid behavior (walking, jumping, etc.) through the base rig, and play your animations in the custom NPC rig. Last I checked, games can get a little slow when they have tons of humanoids, so to avoid doubling your humanoid count you can delete the humanoid from your custom NPC rig and just use AnimationControllers to play rig animations instead.

This method likely has some cons to it, but personally, I think that whatever cons it may have pale in comparison to weird, undocumented humanoid issues, and there’s a lot of them. I remember actually having the sliding issue back in the day, and it went away when I implemented this method of handing NPCs. If you try this method out and have issues with it, let me know and I can try to dig through some of my old code for you in case I missed a step.”

Hope this helped! Also your game looks amazing!

While this could work, there are a lot of characters in this game that could possibly slide around like this. Meaning I would have to re-rig a lot of them to have this honestly quite janky rigging system. I’m wondering if theres any real reason as to why this happening, an explanation of sorts, rather than a jerry-rig fix to the issue. I appreciate the help and the game compliments, but this is a task I don’t think i want to take on if theres any other possible solutions.

Okay, I think I figured out the problem, but weird how it’s the case. Originally, the rig parts were massless, but not the HRP, which caused the sliding issue. Then i made both the HRP and the rig parts massless, and it was still happening. So I reset everything in the rig back to being not-massless (so back to normal), and then it worked fine. Guess the rig didn’t like being massless. Which is weird?? you’d think a rig would work better if it was massless. Oh well, a fix is a fix.

6 Likes