Opening scripts slows down Studio a ton

This is a brand new pc running Windows 10, and my specs are:
Ryzen 3700x,
RTX 2080,
16GB DDR4 4166mhz

I have no idea why this happens, whenever I open scripts the application slows down and characters appear over two seconds after entering


My system is pretty beefy so I don’t know why this happens, my brothers has also just got a new pc and its fine for him.

Also reinstalled Studio twice, restarted pc etc and have no plugins installed.

Can you tell me using task manager how much of your GPU and CPU are you using? Also does this happen with any other applications or only studio?

Are you in the BETA program? If you are using BETA features, this can lag studio, as some are unstable.

1 Like

No, but I did attempt to apply today.

also when I drag it to a seperate window, it is all fine which is really strange:

  1. What plugins are you using? Plugins have the ability to listen to script changes, so perhaps a plugin you have is doing something performance-extensive when you write code?
  2. Have you tried looking at the Microprofiler?
  3. Have you tried different Render modes? ( File > Settings... Rendering > GraphicsMode )

The first i heard about this issue was 5 months ago and i think the same question was posted on here by a user with windows 10. I recommend just keeping your script editor in a separate window since its the only solution until roblox can find a fix.

Please try disabling GSync.

Thanks, I would’ve never thought that would be the issue. Will ROBLOX ever find a way around this because it will get annoying having to change this all the time.

However I can just make it so G-Sync doesn’t apply to non-fullscreen programs, and playing games windowed reduces frame rate anyways, so it isn’t much of a problem.