Option to Disable UI Editor

Hate to necro this post but could you link to your bug report/feature request so I can help boost it? It’s been 8 months and this thing is still in my face making it harder to see what I’m doing instead of helping.

1 Like

This feature that nobody asked for still exists and gets in the way, please add an option to disable it!

Was a button made to disable the editor but then removed? I can’t see the button shown in the screenshots above


UI Editor is something that bugged me and annoyed my development when working with UI elements inside studio, having an option to disable the UI Editor would be fantastic and won’t have to see the clutter onto my UI creations.

^ Hasn’t bugged me too much but still made me mad. :angry:

There are no alternative ways and workarounds when trying to disable the UI Editor, I do remember a post/reply that showed a way to disable it through folders, could be outdated. Anywho, the Editor itself gets in the way of everything from the top and sides when selecting and scaling UI elements which isn’t a problem too much but still terrible for an experience.

Would love an option to disable this, and maybe to see live sizes/positions of UIs if a developer disables them?


I am once again asking that you allow us to disable the UI editor.

I’m currently trying to cycle through fonts to see which one would be best for a situation, and uh… I can’t see.


The ability to see would be nice. Thank you in advance.


If you feel that you absolutely must disable the UI editor for some particular situation, you can rename the plugin that drives it in your Roblox install so that it won’t be loaded:

1 Like

That this is a well-known trick and is the only way to disable the UI editor makes me sad.

This must be repeated every single time Studio updates. This is a dirty workaround for a problem that is quite simply embarrassing at this point; there has been ample feedback about this since the UI editor first showed up in 2018 with extremely clear examples of this issue ruining the ability to work efficiently on small UI details.

At this point, asking for a way to disable the UI editor, or at least the yellow measurement overlay, feels like a joke. People no longer talk about this on the forum because they are jaded and just use stupid workarounds.

Developers have been struggling with this for two years because Roblox has not dedicated resources to making the UI editor smarter about placement of overlays, and/or has refused to add a toggle somewhere for the overlays. You can currently right click on UI to select UI layers; there could easily be a toggle in this same context menu, just like the “Align Dragged Objects” toggle in the same menu.

In fact, I’m skeptical people use the yellow measurement overlay often enough for them to be worth cluttering the viewport at all times since we mostly work with scale or UI constraints anyway. Maybe they should show up if you hover your mouse over the UI element while it is selected, or with some other context clue.

Other threads about this issue:

It’s also worth mentioning that this same “long-overdue UX improvement” problem also applies to the obstructive part selection box in Studio. Why are these things being ignored for years and years when they have been brought up many times, and are so obvious?


I’m running into the exact issues listed in both of those threads. This really needs to be a thing. Working on fine/detailed UI is SUPER ANNOYING because you have to constantly select and deselect a UI element just to see your changes.

Roblox please, we really need an official way to turn this off. I’m trying to see how different fonts look on a GUI and the editor is so much in the way I can’t see what each font looks like without having to deselect the UI to see the effect and then reselect every time I want to change the font to check the next one :rage:


This doesnt seem to work anymore. Working on UI is impossible for me, any time I hover my mouse on my workspace I get this:

If any UI element is selected the second I move my mouse in the game window it thinks I want to drag it and its unavoidable. It makes working on UI for me a mine field. A giant game window sized minefield. Undoing only works 50% of the time.

I’ve removed any trace of UIEditor.rbxm from both roblox and roblox studio in my local files. Its still there and still broken.

Remove this broken, awful editor.


I had temporarily fixed this issue but anytime studio updates it comes back. Having to clear my entire roblox installation just to update is very frustrating. Remove the UI Editor.

I’m facing the exact same issue. It’s an incredible pain; almost impossible to edit UI. By any chance are you also a Mac user, or is this affecting PC too?

1 Like

Until Roblox removed all known ways to get builtins or until another patch is found, I had written a mod to the UIEditor.rbxm to get around which utiliises a setting inside the shared plugin settings file (A settings file that is shared across local plugins and builtins)

	local setting = plugin:GetSetting("UIEditorEnabled")
	if setting == false then
		plugin:SetSetting("UIEditorEnabled", true)
local plugin, settings = plugin, settings

local versionString = "v1.1"

-- Module scripts
local ActionMediator		= require(script.Parent.ActionMediator)
local CoreGuiManager		= require(script.Parent.CoreGuiManager)
local DoubleClickDetector	= require(script.Parent.DoubleClickDetector)
local FFlag					= require(script.Parent.FFlag)
local RotationBox			= require(script.Parent.RotationBox)
local Rubberband			= require(script.Parent.Rubberband)
local SizeBox				= require(script.Parent.SizeBox)
local DistanceLinesManager	= require(script.Parent.DistanceLinesManager)
local TextEditor			= require(script.Parent.TextEditor)

I know it’s not a perfect solution and doesn’t scale but it was a temporary fix until Roblox did something.


Should mention that my plugin has some options for disabling the GUI overlay from the UI Editor. Cannot disable the dragging behavior though.


This is affecting PC. I had been using @Maximum_ADHD’s mod manager to obliterate the UI Editor by giving studio a blank rbxm file of the same name as the ui editors but somehow the ui editor managed to sneak its way back in and the mod manager no longer works. Can someone please just fix this issue :frowning: It’s making game development almost impossible at this point.

1 Like

Try replacing the optimized version?

1 Like

It’s so frustrating and equally stupid that there’s no way to disable this. Renaming the file every single time an update happens which is roughly once per week shouldn’t be considered a “fix”. If Roblox has users that want to disable something that is quite frankly, completely optional to use… it should come with a viable method to disable it. I am fine with it being in my toolbar but having it show up in every waking moment anytime I deal with UIs or god forbid, my nightmares, I dislike.

Please fix this. It’s been 3 years. Enough is enough.


Is the dragging behaviour built into the Gui engine itself? I deleted the UI Editor plugin and my Guis are still getting arbitrarily selected and dragged whenever I’m trying to work on Guis. It’s incredibly infuriating and distracting.

I’m spending precious development time constantly undoing drags and it just keeps sinking my mouse. I don’t get why, not sure if it’s a bug or what. If I reselect a Gui I’ve previously edited after clicking in the world editor, the Gui just gets dragged around permanently. I never even clicked the Gui but it just enables dragging anyway and messes up my positioning.

We need this feature please. This is making interface development more challenging than it needs to be and there’s never a case where I ever want to use this feature, it’s not helpful to me at all. One of the most frustrating features shipped to the platform with weirdly no way to get rid of it.


Interesting. At least of MacOS, removing the two UIEditor.rbxm files completely disables this functionality. Perhaps this is a Windows-specific quirk, or maybe there are other supporting files in that platform that also have to be removed.

The UI Editor makes it literally impossible to edit small UI elements, somewhat ironically.

It’s such a monstrosity in size that it is literally larger than many of the smaller buttons and such that I’d want to change. It is absolutely abhorrent.


Is there still no way to disable this? I never even use the UI Editor as I’ve been making UI far before this was introduced and it’s a huge blocker for me at times, especially when working with small buttons and text (image related)


Hehe, I found it out!


Source code for the plugin
local CoreGui = game.CoreGui
local toolbar = plugin:CreateToolbar('GibusWielder')
local toolbar_button = toolbar:CreateButton("Remove UI editor", "Attempts to remove the UI editor, if it didn't work the first time", "rbxassetid://10281560445")

local function removeEditor()
	if CoreGui:FindFirstChild('RobloxGUIEditor') then
		local editor = CoreGui.RobloxGUIEditor
		if editor:FindFirstChild('ValueBoxes') then
			editor.ValueBoxes.Enabled = false
		if editor:FindFirstChild('DistanceLines') then
			editor.DistanceLines.Enabled = false


	if child.Name == 'RobloxGUIEditor' then

Edit: fixed the plugin not working when you restart studio

Though… this shouldn’t be the final solution. Roblox should definitely implement this as me, and a lot of other people are not too big of a fan of the UI editor.

1 Like