Output window gets slower and slower

While debugging, as the script prints something to the Output Window, it gradually gets slower, until practically stopping the game, after many prints …
If I clean the Output Window (Ctrl+K), it will be fast again, then everything will be repeated …
Is there any way to avoid this?

Is it printing too fast? if so, then that may be the reason why

Couple options. You can either temporarily disable the new output window (it’s still in beta so bugs should be expected):


Or make a bug report on the new one with a microprofiler dump and system information.

I indeed remember the old one not being slow even with spammed outputs.

1 Like

Yes, that’s because it takes up memory, there really isn’t a way to make it go faster, you can possibly get more RAM or you can clear the output window. Alternatively, use less statements that clog up the window.

In fact, I use the Expressive Output Window beta and when I activate log mode, this problem does not occur. I will create a bug report. Thank you.

1 Like

Solved in version 454.