PackageLink AutoUpdate does not destroy outdated model and repeatedly inserts over the old one

When a model’s package is updated, all other models with their PackageLink AutoUpdate property set to true, should have the old model deleted and replaced with the newest version. This is the expected behavior.

What currently happens is that the newly updated model is inserted and the old model is not destroyed. This is problematic because it creates a mess of lag in your game when models are essentially duplicated repeatedly in the same place.

I’m only able to reproduce this bug in a specific game of mine, and the steps to reproduce it are just to publish changes to a package. I tried replicating this bug in a separate empty baseplate but it worked as expected and the bug did not occur. I suspect this may be due to my game’s scale and/or part count.

This behavior can be seen in the following video.


Hi @TheFurryFish, thanks for reporting! We will look into this issue.

A few questions:

  1. Is this a group owned package or user owned package?
  2. Did you share the package with someone?
  3. Is teamcreate enabled? If so, if another collaborator is online?


  1. This is a group owned package.
  2. I’m not sure what you mean by share the package with someone. It is a group owned package that I created in the team create session with other collaborators online.
  3. Team create is enabled and there were 2 other collaborators online I think.

Great! That’s all I need. Thanks!

Hi @TheFurryFish, I’d like to confirm that when an auto-update package is duplicated, both of the packages are at the same version, which is the latest version.

Oh ok, I don’t think I meant that the original package was outdated when it was duplicated, but that it wasn’t destroyed when being automatically updated. My apologies, I could’ve been more clear.

Thank you for confirming this behavior.

1 Like

Is this the intended behaviour? It doesn’t seem like it to me.

I had this exact same issue and resorted to deleting the duplicates where they occurred. Not all of the packages that were updated had duplicates, which makes this clear that it’s a bug. Duplicated packages were both the same (latest) version, and there were definitely not duplicates before.

  1. This is a group owned package
  2. The package is used in 2 places, one local file and one published (group) game
  3. Team create is enabled in the place the packages were auto-updated in, I had one other collaborator online
  4. I published the changes to the package from the local file
  5. There were 34 total packages (plus the one in the local file), each containing a few hundred parts
  6. Just over half of the packages were duplicated

Hopefully this can be fixed, it was annoying to remove each duplicated package. Luckily, Tomarty’s Geometry Tools helped to locate duplicate parts, making the process a bit easier to resolve (for anyone who is also having this issue before it’s fixed).


We are working on a fix for this. Please check it here. Thank you!

1 Like