Packages getting Web Copy Error: Http fails

Just wanting to add on. For me it is now happening every single time I attempt to publish a package and it is really messing with my workflow. It does not seem to happen when updating a package, only publishing them makes the web copy error appear and leaves studio unsaveable.

1 Like

image

Bip-bump.

06:35:47.697 - Fifkee committed a new version of script ReplicatedStorage.ModuleScripts.BattleAPI.BattleAPI2
06:38:12.489 - Request Package 4741133618 V54 Web Copy Error: Http fails.
06:38:41.592 - Test Palace 1 auto-recovery file was created

Getting this one too. I have to restart my studio when this strikes, since I become unable to upload any packages. Man, I wish we still had LinkedSources.

Can you use the following template to report the issue?

Place Type: TeamCreate/Non-TeamCreate
PackageType: UserPackage/GroupPackage
PackagePermission: Own/Edit/UseView
Step to Reproduce: If the bug is 100% percent reproducible, please provide minimum steps to reproduce the bug.
Other Information: Things you would like to share.

Thank you!

Place Type: Non-TeamCreate
PackageType: UserPackage
PackagePermission: Owner
Steps to Reproduce: It isn’t entirely 100% reproducible but hopefully what is explained below can be a good enough summary.


History:
When I started using packages in my game possibly around December - January I very rarely had this issue and cannot bring up a time I had it. But ever since the last few weeks it started to happen quite often (maybe 1 in 5 times you published a package) but now it seems to occur about every single time I save a package. Maybe it is related to the increased traffic lately?

Package/Game information
A few of my packages are usually huge in instance count too and some of them have inbetween 50-150 versions but it still occurs on packages with very little versions or instances.
My game (game id: 621378811) has about 60 packages.

A few of my packages that errored: ‘4870356003’, ‘4324815481’, and ‘4325056394’.
One thing all of these 3 packages have related to each other is there’s at least 1 ModuleScript within them.

I have also noticed that this is not always right as soon as you publish a package and that it can occur a few minutes after updating them. Just today, one of my packages ‘https://www.roblox.com/library/4325056394/ServerModules’ errored within a few minutes of updating it a couple times with slight changes. Error: Request Package 4325056394 V137 Web Copy Error: Http fails.

After one package erroring it seems to continue the trend for any packages you update after that one.


TL:DR: This issue has been going on for as long as at least October of last year and has clearly been getting much worse within the past few weeks.

I posted a couple times before on this post so I hope the information from them can also be of help.
Let me know if you need any further information and I’d be happy to supply what I can. :slight_smile:

Place Type: TeamCreate
PackageType: UserPackage (I gave permissions to my friend too)
PackagePermission: Own
Step to Reproduce: Have a package in your place and try to save it.
15:10:49.838 - Connecting to server…

15:11:30.987 - Request Package 4902136687 V6 Web Copy Error: Http fails.

Didn’t do anything else.

Other Information: Package does include a module script, in case that info is pertinent.

Thanks for the feedback!
We’ve taken some actions to mitigate the issue. Please restart your studio to get the fix and let me know if it works.

1 Like

I get the following message with the latest studio which is the same as before:

image

I only have two packages which are both set to auto update:

image

image

One thing that is notable is that even though it is set to auto update, the guipackage does not turn link blue. I have been unable to make this work and am open to suggestions.

Although it is grey in the link color, it shows as being up to date as well:

image

Currently having the same issue. Packages are set to auto update, get greyed out, the auto update fails, web http fails error is printed to the output, and all the properties are shown as up to date with the link still greyed out.

2 Likes

We’ve been having this issue occasionally for the past month too.
It’s very frustrating because we cannot publish our game while its happening.

The only workaround that sometimes works is to:

  • Open a separate place
  • Insert the package
  • Make any change to the package.
  • Publish that change and hope it goes through
  • Reopen the place with the package, which should now be marked as out of date
  • Try publishing again

cc @billlipeng

6 Likes

Thanks for the detail. And yes. A temperary workaround is to save the place, close the place and then reopen it. Everything should be back to normal. For teamcreate place, you’ll need ask everyone to quit the game and wait for a while before reopen it. Sorry for the inconvenience! We have identified the issue and are working on a fix for it.

5 Likes

Any ETA on when this fix will be released? I have been forced to remove all packages from my game and just replaced them with folders (forcing me to manually update across all places for the time being) which is a rather large inconvenience. Would like to go back to using packages but not until the issues concerning it are solved.

5 Likes

I’ve just released another patch to mitigate the issue. Can you restart the Studio and try it out? Since I cannot reproduce the issue on my end, please let me know how the patch goes. Thanks!

1 Like

Hi… been unfairly banned for about two weeks - just got unbanned last night. I’ll look into re-adding packages to my game and update depending on results.

1 Like

I did get the usual error message just now (hadn’t gotten it for awhile beforehand), but the methods to reproduce are kind of weird. I loaded an autosave, with packages that auto-update… and when I updated the package, it seemed to go through. But when I hit Alt+P (expecting the menu to come up), it gave the error and the menu didn’t come up. Then when I hit File>Publish to Roblox As and selected the game manually from there without using keyboard shortcuts, I didn’t get any error messages.

Ok, nevermind - can confirm it is 100% still bugged, same issues still happening when I try to publish using Alt+P keyboard shortcut, however it works fine if I click the button in the menu.

Hi @FumeiSencho. Can share the detail of timing when you reproduce the issue? E.g. after publish a change to the package, after 5 seconds, hit Alt+P, etc. Thanks!

Ah, I see - if I do it almost immediately or after just a second, it gives the error, but if I try again after a few seconds, it works now. Before, it wouldn’t work at all.

1 Like

Ever since the fix I have received this error a couple times when attempting to publish package(s) that have changes that haven’t been published and also is in need of an update (so a green and orange icon)

image
"Error publishing Package: "

Studio wasn’t responding each time I got the error. After the window is no longer frozen, it failed to publish the package. No icons have changed. Attempting to publish it again was successful.


And an update on the error shown here: I haven’t had any problems with it so far except for me being unable to save while the package is updating which takes longer than it used to.

Hi @Evercyan, can you please follow the bug report guideline here and provide minimum reproduce steps? Thanks!