Painful lag when resizing parts


I lag terribly hard when I resize parts, or paste parts into a model or folder.

Is anyone else experiencing this? It started this morning and I am clueless as to what caused it. I also reinstalled studio, however that didn’t seem to fix it.



I noticed that it does NOT lag when resizing a model. It also lags when I undo the resizing of a part.

1 Like

I had this problem once but reopening studio fixed that for me. I’m not sure I think you have a more in depth problem.


Does your workspace look like this by any chance?

Delete any Humanoids directly under the workspace.


Negative. No loose humanoids in my game.

1 Like

Do you have any plugins?
Are there any beta features enabled?


Try disabling collisions and join surfaces
(disable snap to parts if you have the beta enabled).

This is weird.

Few more questions:
Can you reproduce the issue on a new place?
Is team-create enabled?
PC specs?

1 Like

Yes, I have plugins, however they are all up to date, and trusted. They have never caused any issues before.

Snap to parts.

The issue doesn’t seem to appear on a fresh baseplate?

Yes, this game is a collaboration between me and a good friend of mine.

I don’t have access to my main rig right now as it is broken, so I am using my laptop instead.

2022 Acer Nitro 5
Intel i5-10300H
RTX 3050
256 GB SSD
Win 11 OS

1 Like

This still hasn’t been fixed. I haven’t been able to develop all day.

1 Like

This still hasn’t been fixed.

I am barred from developing until this is resolved.

1 Like

Well if this issue does not happen on a fresh baseplate, it might be about how much memory you are using in your current project. You can see how high your memory is by using /console inside of the chat. Check it out if your memory is above 3,000mb that could be an issue with a laggy game.

1 Like

Do you know if the same game doesn’t lag without team create?


I can’t disable team create, the game is under a group

1 Like

Imeant trying copying it then testing without team create

Can I see what the game looks like it could be a specific mesh or too much detail in one specific place and you may have to optimize that area

The problem is most likely related to this because I’ve had the same issue:

If that is not the problem, you could still have a humanoid somewhere and you just don’t see it or you could have virus from a free model

Try downgrading Studio graphics if all else fails

Can’t be. This is all I have on the map right now, and all of the models you see are within the acceptable tris/part count range.

Okay so it seems like temporarily setting the graphics to 1 and then back to the original level fixes it. At least that’s what worked for me.

Thank you, you’re a real one :pray:

Those trees at the bottom-left of the screen look like they use a lot of parts so you may want to reduce your part count

and make sure to mark a solution because other people may encounter this issue as well

Those have been there before and never caused performance issues.

I’ve experienced similar issues: Working on a large project with Team Create is a miserable experience. A master list

Seems like Roblox has been improving these problems. It’s gotten better for me (though still not great at times)

1 Like