Part offset when moving model

(I suspect someone has brought up with issue before, but I can’t yet find out where, sorry if this issue has been addressed already)

I’ve been encountering an odd studio bug for some time relating to a slight offset when moving models in studio mode. I first noticed it around 2 months ago, though I assume it has been a problem before that, and have had to deal with it ever since.

On the right, is the original model, while on the left is the same model I have copied and moved and rotated many (~20) times. This problem occurs every time I do this test. Ideally, I would not have to worry about my model breaking when moving it around a lot. I know there are problems with parts offsetting, but this is an odd instance where the model and its parts are being moved on a perfectly 0,0,0 baseplate. I would love to know if there is a solution for this.

13 Likes

I can relate.
It happens when you try to move a part too

3 Likes

I’m having the same issue. I start screaming for vengeance like Rob Halford and then jameeish has to hold me down so I don’t disturb everyone else around the office.

I’ve had parts change Y axis by like .001 when I haven’t even moved them vertically with SBS. I’m assuming it’s just something as mundane as a rounding error or something like that but it drives me up the wall every time I see it. It really slows my build times down when I have to put down what I’m doing to make tiny changes to the positions of parts to what they should have been in the first place.
It doesn’t just occur for me with SBS, either. It also happens with studio tools and F3X.

5 Likes

I get these pretty often if I turn off the increment. One part kind of causes some other parts to have a slight offset and it’s really difficult to get right.

But, you could try using the Transform tool. I’ve used it when stuff isn’t accurate, and it can be aligned perfectly sometimes. Wish the other tools would align better too.

1 Like

This happens to me all the time and it drives me insane. I don’t know what is causing it. I only resize and move everything on a 0.1 stud level and somehow my parts still get randomly offset to smaller increments, on position and size.

2 Likes

Does anyone have a solid repro for this? I’ve tried making parts and moving/rotating them, but they work fine.

This is still happening and very annoying as a builder as I am unable to resize/move quite a lot of parts because they keep offsetting. What’s worse is that this is random with no way to repro this. I am finding this very limiting in my building work.

2 Likes

I know how to fix that: Firslty remove all Welds of all parts, and also uncheck “Join Surfaces”, that worked for me! :slight_smile:

1 Like

Never had welds on parts and “join surfaces” was always unchecked. Anyway not particularly relevant now since I haven’t had the problem in years.

I just lost a few hours of work due to this issue. Parts randomly move by ~0.003 studs and the whole build is corrupted. I don’t even know how to reproduce this, it happens at random.

2 Likes

Here are some things that can contribute to reproducing the bug:

  • Using “Select” tool to drag parts
  • Copypasting parts a lot (probably this one)

It’s still present and it’s very annoying. Please fix.

2 Likes

I found the ultimate 100% working repro for this bug:

  1. Place a part below another part
  2. Copy and paste that part
  3. Try to drag it (sometimes bug happens without this step)
  4. Check its position and be satisfied by the result.

It happened on my development real side too when part welded to other part unanchored goes by entire parts, 5 meshes move on each move if i try to put it back, was frustrating and hard to get it all aligned.

1 Like

Can confirm this has been happening to me too.