Particles’ Flipbook Release

I’ve waited so long for this, and I’m excited to make use of it! This will really help save memory around particles and instead of having to use one Particle Emitter for fire, smoke, and ashes, instead I’ll be able to merge them all into one object.

1 Like

I agree 100%, with solid shapes and longer lifetimes the fading just looks bad.

1 Like

This is going to break roblox, 3rd Gen of Particle VFX is going to happen!!! The particle market is going to skyrocket, real!

4 Likes

Time to flip out crazy and update my combat particles.
GUYS, IT’S REAL! MY UPCOMING GAME IS GONNA HAVE smooth PARTICLES!!!

2 Likes

Yeah, this is absolutely rad, even with the image size limitations.
For those wondering, yes, I made these particles from scratch.

39 Likes

Amazing work! Can’t wait to use this!

1 Like

This update is really cool, but it will be really cool to add particle physics and better to control the particle movement.

Finally I will be able to use several amazing visual effects!

I still don’t understand why there is not support for our own Flipbook Layout values, I can nearly achieve this same feature with a billboard GUI and an imagelabel, and even then I have heaps more customizability, what’s holding back having custom options for flipbook layouts? (eg you can set number of row’s on the X axis to 5, and you can set number on the Y axis to 7 etc etc)

I really see a lot of potential in this. Really grateful for this awesome update!

So i can make ps2 menu with partições?

When too many particles are in the workspace, the particle emmiters take way too long to enable/disable, regardless of how many are actually on. Here’s the repro file: EMITTER_BUG_REPRO.rbxl (40.5 KB)

I hope this gets fixed, its very annoying.

7 Likes

It’s about time we get the flipbooks feature. But I have 1 more feature request.

Would it be possible to just outright remove the render distance limit for particles on 8+ graphics? It really infuriates me because I have a huge map where I need particles to be visible at any distance. But if the camera is just even 1000 studs away from the particles, they just disappear straight up unless on graphics 7 or less. I have to use the emit method just as a workaround for the particles no longer emitting if the camera is too far. But now I have to deal with particles just straight up not rendering if the camera is too far.

1 Like

This is going to be so awesome. I can’t wait to see games start to use this. Thank you :slight_smile:

Unrelated-ish, there is still the beta note on the docs:

3 Likes

FINALLY! We’ve all been waiting on this

YESSS LETS GOO FINALLY THANK YOUu.

Exactly what I need. It’s delightful to make realistic puffing smoke for steam engines and stoves! Thanks! :slight_smile:

O_O WOW that is… I am beyond words right now

hey, thanks for doing this. One major issue is the degrading of resolution once importing flipbooks into studio. I have created high quality flipbooks in 1080p, once I import it looks like 120p or something along those lines. higher quality look at the degrading quality

Please grant us with the feature of uploading high quality textures for flipbooks!

15 Likes

LETS GOO NOW WE CAN MAKE MUCH BETTER THINGS it is so exciting man