Parts not auto snapping/rotating when dragged onto other parts

Cutting to the chase, my parts no longer snap/rotate to have a similar rotation to other blocks when I drag them to another part.

Normally my parts will do this:

Expected Action


However they do this instead:

Actual


What have I tried?

  • Disabling all beta features
  • Disabled/Updated plugins
  • Tried on baseplate/saves
  • Used all tools and toggled respective settings (Collisions Etc.)
  • Restarted/Reinstalled Studio
  • Reset Studio settings
16 Likes

Do you remember any last modification/adjustment that you could’ve made before this problem was encountered?

1 Like

No I haven’t modified any studio settings

1 Like

I’d personally recommend to try and checking out the F3X Building Tool Plugin if you haven’t done so yet. I’ve never encountered any problems with parts in the past with this thing, it’s a really nice polished plugin that’s very easy to use.

https://www.roblox.com/library/6490800228/Building-Tools-F3X-Plugin

I also have this problem, would be great to see some solutions for it too!

1 Like

This isn’t a bug, it is intentional. If you want the expected behavior, Right-Click > Align Dragged Objects.

38 Likes

Though I’m unsure when I ever turned this off, thank you for the solution

This (align dragged objects) will cause the parts to align (become co planar), but not to vertex snap. Looks like a bug to me.

Thought studio updated and other stuff. :laughing:
Thanks this saved me loads of time :skull:

1 Like

Yikes, this was a massive headache to figure out, even as a 14 years roblox veteran. Roblox Studio updates and suddenly parts don’t align with the objects you drag them on, lol.

Why isn’t this in the Model tab?

It’s the same thing as World and Object Space, but at least that one has a shortcut.