Parts shifting ingame

When I play my game, random bricks start to shift randomly. They are not far away from the center, just 100 to 200 studs. It’s occuring whenever I, or other people, join the game. It does not occur when I’m editing in studio, or when I test it in studio. It started happenening a few days ago.

Please note: I’ve seen bugs like these for meshes and unions, but it never seemed to happen with parts. It’s the first time I see this happen.

These pictures should pretty much describe what is going on.
In studio:



Ingame:

image

12 Likes

Are the parts Anchored? Also, please leave a link to your game.

Yes, all the parts are anchored.

Game is found here:

When everyone is done looking around, any chance you could notify me again? It originally was group-only as it is being tested right now. Made it public for this purpose only.

I have experienced the same bug multiple times.


Everyting is fine in studio but when I play it in game it shifts for some weird reason.

5 Likes

Same thing happening here, extremely frustrating and confusing.

Studio:

Online: image

Everything except the train are anchored, and there’s no weld scripts whatsoever going on in the game…

4 Likes

Just to be clear - this is expected in general because we currently use a slightly imperfect rotational representation for replication to conserve bandwidth. However, this hasn’t changed in years. So I’m not surprised that this happens at all - I’m surprised that the OP implies this started happening recently (there weren’t any changes in this area for quite some time now).

We’ll take a look at improving the precision here, but I want to understand if there was a regression here recently or not.

6 Likes

What kinda annoys me is that this apparently was a known issue for years, and that it hasn’t been fixed. I know there might be a lot of things that require work, but this seems to be a really crucial one to me.

3 Likes

This


implies that there is nothing to be fixed. It’s a known issue, but it seems Roblox has determined that it is a necessary sacrifice. Most programming decisions have trade-offs in one form or another. Though unfortunate, there’s really nothing to be done.

2 Likes

any update on this? We’re still experiencing this problem at Terminal Railways

Same here. I’m actually seeing the amounts of parts shifting increase while the game hasn’t increased in parts between the posts.

1 Like

We haven’t worked on this since; again, my understanding is that this is a fundamental issue - it’s not a regression of any kind. Our physics system currently uses intermediate representation that is somewhat different from what is stored in the file, so this is unavoidable. Not sure when this will change…

3 Likes

In my train sim game, the devs and I had experience this issue in some places around the map. The location is pretty far away (48, 000 studs rough estimate). It was meant to be an extension from a specific region. However brickshift are pretty much appearing everywhere around the map even areas that are in the same region to the centre of the map.

  1. 48, 000 studs from the centre (one of my devs estimate the distance by using 2000 studs long part connected each other). The brickshift is so serious that trains are unable to get pass the tracks.

  2. In the same region from the centre of the map (9000 studs est)

7 Likes

I find it funny how this is 3 year later and the bugs are still the same. I am also noticing more brickshift occurring when I am building about 2000 studs away from the origin, compared to when I was building at the origin.

1 Like

Is this a new issue? If so, is this only happening in Studio? Also are these parts anchored?

I have noticed this occurring when separating unions in studio.

Here is the position before separating (I have made the union red so you can see it)

Then here is the position after separating

As you can see it moves downwards, although if I then proceed to separate it again it shifts around even more.


(It has now moved upwards)

Another things to point out is that the selection box is offset after doing this.



As you can see there is nothing sticking out that would be causing the selection box to change.

Thanks to all of this it is not possible to continue making the rest of the train cars due to me needing to separate the body unions.

I know it might be a hard thing to fix, but so far I have seen no attempt of it being solved.
ALL of the parts are anchored, and I am only building 300 studs form the 0, 0, 0 origin.

I see, thanks for explaining. The issue you described is a separate issue from the one in the original post, would you mind making a separate bug report specifically for this issue in Studio? In case you’re not familiar with the process, you can check out this post: How to post a Bug Report

Alright so I just encountered a group of parts shifting in game but not in studio as well.

Here it is in studio:

And here it is when you playtest or enter the game

Trains are unable to get past this point and derail instead.
Something interesting I noticed however was that the position and size of the parts stayed the same, even though you can see that the position has changed:

In studio:
image

In game:
image

Another interesting thing is that unlike Parts shifting ingame - #15 by Trainity_RBLX these shifted parts are quite close to the origin.

1 Like

I don’t believe anything has changed in this area recently, this seems like a limitation of the representation we use when replicating a part’s CFrame (very small rotations might not be replicated). This isn’t new, but if you could send me a repro file I could confirm that’s the issue.