PBR Texture flickered on Skinned Mesh animation [MOBILE EXCLUSIVE]

Description
What happened here is when a skinned mesh in animated and surface appearance is applied with color map and normal map, this texture flicker will happen on mobile. It does not happen to any other cases.

Reproduction

  1. Apply SurfaceAppearence to any animated skinned mesh morph
  2. Apply ColorMap & Normal Map to SurfaceApperance, set AlphaMode to Transparency
  3. Put Mesh RenderFidelity on Automatic or Performance
    CONSISTENT

Expected Result
Same as the video provided, but the texture does not flicker. Example below:

9 Likes

Some Q’s, what device are you using? Does this happen when the Mesh RenderFidelity is set to Precise? Is there a place we can look at to reproduce the issue?

The video was recorded on an iPhone 12 Pro Max. I am not sure if it happens o Precise, because I have a blurred memory of testing it on precise, but mostly I remember the result is still buggy.

You can test the bug in this game: 🔥EVENT🔥 Digimon Masters - Roblox

Simply join on mobile and select Botamon, then spawn area.

There is another bug that has been happening consistently after release note 490 on skinned mesh animation. Rigs that has more than one parts now occasionally breaks when morphed. These rigs worked fine before the patch.

This bug is confirmed to happens on any RenderFidelity.

1 Like

Is this bug still happening? (This was reported quite a while back, so just making sure it is still an issue or not)

I just tested and the bug is still happening on any RenderFidelity and on any Graphic Settings.

If this is a separate bug, can you make a new bug report with repro instructions? Thanks for your help.

FWIW we have narrowed down the glitchy problem. However this will involve a couple more people, so this might take a couple of days.

In any case, it is being looked at.

3 Likes

Just so we’re clear @Sir_Bedevere is talking about “There is another bug that has been happening consistently after release note 490 on skinned mesh animation. Rigs that has more than one parts now occasionally breaks when morphed. These rigs worked fine before the patch.”, which is different from the graphics glitch… and they are internally handled by 2 different teams.

1 Like

The bug with Sir_Bedevere has been resolved (where the mesh becomes a squished ball) by Sir_Bedevere reverting the update on the place; however, the bug with PBR texture glitching has not been resolved. Just to confirm, only the graphic glitch remains for now.

2 Likes

Hey, so the squished model bug just randomly returned again…

Hey, so the squished model bug just randomly returned again… I haven’t update the game or anything yet. Something must be updated in ROBLOX internally. The bug only appears to happen on rig with “RootPart” (multiple part rig), and appears fine with rig with one part.

So sorry about that, we are looking into it now. Just to confirm that is only in this place?

That’s not a universe, and no other places or universes are involved?

Yes this is the only place. No other place, no universe

Can you check again and see if it’s working now? It may take a few minutes to fix, but hopefully soon.

1 Like

The bug is still there, but let’s wait for a bit.

Also, it should be fixed by now. If not, let me know and send the most recent log if possible.

1 Like

you can look in
C:\Users\ username \AppData\Local\Roblox\logs

The bug is still here on a very new server. I just updated the game too.