PBR Textures not appearing

Hello, I am having an issue with my mesh not showing its PBR textures. I’ve was following this post that has a tutorial on how to add PBR textures in blender than import it into studio. I did everything and followed all steps but still my mesh didn’t show its PBR textures in studio.

Link To Post

PBR Support for the Unified Smart Mesh Importer Beta

Textures Shown In Blender

Textures Not Showing In Studio

Please help me find a solution because I am pretty sure I did nothing wrong.


Hi Uhtred!

What format did you export your model in?

Would you send a picture of your blender texture node setup?


I used fbx file.

1 Like

Did you try using a SurfaceAppearance object in studio and, if so, could you please provide more screenshots?

Regarding the SurfaceAppearance object, you can add a ColorMap, MetalnessMap, RoughnessMap, and a NormalMap:

1 Like

I’ve done it before and yes it does work. But roblox doesn’t have settings where I can adjust the texture. So that’s why I was using blender in order to adjust my texture onto the mesh.


What exactly do you mean by “adjust the texture?” Do you mean UV mapping?

You can’t get a PBR texture like this, because all the data is converted to 1 texture (I think just the diffuse). If you want a PBR texture, you have to bake the other maps.


Well, I assume they already have all the maps needed - all that’s left is to import them, their blender node setup clearly shows several maps already manually plugged in (BaseColor, Metallic, Roughness, and Normal).

No, that’s not how that works, because you’re not taking the shader with you. You’re taking the diffuse texture.

You must:

  • UV unwrap your model
  • Create an empty image texture in your shader
  • Select it, bake your [normal, metalness, roughness, diffuse] map to it.
1 Like

I meant they already have a downloaded image of their maps including the diffuse.

Such as the ones below that are pre-made and downloaded instead of manually baking them, which doesn’t seem to be necessary.

(might be misunderstanding you, so please clarify if I am)

You’ll still need to UV unwrap, if it’s a custom model. You need to import these textures individually, and then set them to the proper input in the surfaceappearance (Always have to do that for pbr)

1 Like

Seems he’s already got the UV mapping part down, once again, check their blender node setup.

You can’t conclude anything from the mapping node. That’s basically default.
Bad UV unwrap = bad texture projection in Roblox.

1 Like

The UV map seems to be perfectly fine according to the image they provided in the first post, it seems they’re struggling with the texture appearing in studio, rather than it projecting correctly.

Make sure you disable the texture on the meshpart. That can interfere with surfaceappearance. Then, you should check if you can import the textures as a decal: if not, Roblox may have blocked the upload.

1 Like

How can I do that? I am pretty confused right now.

I just checked and actually SurfaceAppearance seems to override the textureID of the mesh. Try importing your textures as images. Then, add their ID’s to the surfaceappearance’s appropriate slots.

Does the warning signs have to do with any of this?

In Blender

In Studio

It automatically removes the textures and also doesn’t add surface appearance.

Okay, finally I found the solution. I knew the warning signs meant something so what I did to fix it was to click on the File logo and put in the right texture (Normals, Metalness etc). We just have to do that manually and the UV mapping you did from blender will be saved. I don’t know why we have to add in the texture again but maybe Roblox didn’t catch it.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.