Place upload failed when attempting to publish descendant assets. Failed to Upload Union

Just a few days ago, I was able to upload this entire place repeatedly, all at once, without issue.

This place is about 40,000 parts and starting on Monday I started getting this dreadful error.

I started playing around with the place to see how much I would have to delete before it allowed me to publish to roblox again and I ended up having to delete over 2/3 of the map, which I was able to upload previously as a whole
Did something change with Studio? Not only is this costing me precious time as we approach my update release goal date, it made me lose an entire day’s worth of work because it didn’t actually publish when we were working in the team create on Monday. I need answers and I need them fast. This is not right, help would be much appreciated.

The place can be found here

A private message is associated with this bug report


the last error provides why it failed, it exceeded the limit, maybe one of your unions are too much for the game?

as I JUST said: nothing changed from the other day when I was able to upload everything with zero issue.

1 Like

Odd. Roblox did just recently Update Studio. So it could be issues relating to that. Other then that I am really not sure.


I’ve been experiencing this issue myself for a couple weeks now, and it sure is a frustrating one. From my experience, it’s definitely some issue with large unions, and might be exclusive to CSG V3, but am not entirely sure. It’s not a one-time issue, either; affected unions, even if you re-union them together from smaller separate unions, will corrupt again in the exact same way, for no apparent reason. Sometimes, copying-and-pasting the union from one place to another, assembling the union there, and copying it back into the original place will fix it. Sometimes, the union will work in one place, but not the other. Sometimes, it will break in both places. I cannot, for the life of me, figure out the rhyme and reason behind this.

The only real way I’ve been able to fix this is by manually locating the problematic unions (basically just guess-and-check, deleting stuff you’ve done recently until your publishing works again) and reworking their innards, or sometimes splitting them into separate unions entirely. I initially had some luck in reinstalling Studio, that seemed to fix it for a little while, but subsequent reinstalls were not as successful. I heard from someone that doing your union-making in a local file might solve it, as Roblox doesn’t have to funnel those back through their servers or whatever, but I haven’t really tried it myself.

I really hope this gets fixed soon, it’s absolutely ruined my ability to get anything done, having to constantly check for a single union putting my entire place file into jeopardy.


Yeah, I even tried isolating problem unions and tested publishing until it works. Issue is that when I’d get down to a specific area, sometimes it would work and sometimes it wouldn’t so I am unable to figure out what specific union is causing it


It’s real nasty, as the only real way to tell exactly which one is causing it is to delete increasingly smaller and smaller batches of unions until the only one left selected is the problematic one. I’ve had to do this multiple times, and each time it becomes more and more infuriating. I really wish Roblox would highlight any unions or other objects that were causing errors, or at the very least flag them in the Explorer or something.

1 Like

thats actually what I did. I got it down to 10 and then when I was deleting one by one, sometimes the same one would publish and sometimes not. It’s crazy…

1 Like

I really wish that since it gives an error for it already, that the error could just include the “problematic union(s)” .
Ive had this before and usually end up either waiting a while and trying again or un and re-unuoning the stuff
(sometimes into smaller parts, sometimes into less steps)


Thanks for the report! We’ll follow up when we have an update for you.


I have assisted @BuildIntoTrains with this, and it was still not allowing me to publish the same place from my end as well.

EDIT: I did not mean to delete that post

1 Like

I have been experiencing this lately myself. I thought it was the size of the place file that I was uploading. But at least I’m not alone in having this issue. It started happening to me a few days ago. It’s very sporadic. If I can’t save the place to the cloud, then I just save it to a file and try again later.

1 Like

I appreciate the response and hope you guys can help me before this long weekend. I want to be able to make progress on my game that has a tight deadline that I’ve already had to delay due to this

1 Like

Just as further info: I’m also now getting this error:

Currently running into the same issue myself, was attempting to upload a place into one of my experiences so my developers could access it, and it failed to upload. I tried downloading it manually and doing it that way, but it still threw out the same error. Hopefully Roblox will fix this issue ASAP.


what I ended up doing is copying and pasting 300 parts at a time into a new baseplate and publishing each time. If I got the error I would undo a paste, then copy and paste a smaller group until it continued being able to publish. Took me 14 dang hours

1 Like

From my experience, any error along the lines of “Failed to upload union: exceeded limit” is due to bad internet/internet problems, IT IS MOST LIKELY NOT FROM PROBLEMATIC UNIONS OR HAVING TOO MANY.

From another thread, I was talking with a staff member and they mentioned that the message is indeed problematic, and misleading, because obviously it says “exceeded limit”, implying you hit some sort of limit, when in reality, it just failed to upload due to connectivity to Roblox.

I’ve looked at my logs when I had these problems and it became apparent it didn’t even try once to upload my unions.

Keep in mind this isn’t only caused by poor internet, this also can be caused by Roblox servers having issues.

1 Like

I know its not my internet because all of my friends couldnt publish the file of my place either, and I’ve been able to upload that exact place a week earlier with no changes

Definitely has to be a Roblox issue then.

You’ll have to wait a while (up to a day or more) for this to resolve.

Still unable to publish? I’m unable to publish an existing place with 0 changes and its not even trying to publish, or giving a meaningful error

It has been 4 days of constantly trying and its refusing