Players get teleported to a different server instance while using the same reserved code on Xbox

We’re having an issue in our game ALONE Battle Royale where Xbox players can’t seem to get in the same reserved servers even when using the same access code.

The wiki page for ReserveServer explicitly states the following:

  • No more than one game server instance can exist at any time for each access code

In reality, this does not seem to be true, and it is completely breaking the game experience for Xbox players. They might join a match with 30 players, but end up being the only player in the server, with the game getting stuck in a waiting state.

A few notable things:

  • The game is labeled as needing to be updated on Xbox, with the old warning from when Experimental Mode was still around on the game page. Maybe related?
  • All of the places in the game universe are set as playable on Console.
  • There is a previously unresolved thread with what seems like a similar issue, but it is pretty old, and Experimental Mode was still around back then.


Teleporting has now become occasionally super slow on PC as we’re getting more and more players on Xbox. It seems as if maybe one platform starts a reserved server, and then the other has to wait for that server to disappear until it starts it own, using the same reserved code.

After a while, teleports seem to time out, giving this message:

Teleport failed due to an unexpected error (Error Code: 769)

This is completely game breaking at this point.

1 Like

Thanks for the report, we are investigating this issue.

1 Like

We think there may be a bug on our side. In the short term, if you explicitly set Workspace.FilteringEnabled to true for place id 2856822203 (ALONE: Matches) we think it might help.

1 Like

I manually set FilteringEnabled to true and published the place a couple hours ago. I also shut down every active server in the game and made sure there are no old servers left. Nothing seems to have changed, so far.

EDIT: I tried manually teleporting to the place in a live server and then shutting down active servers again. This seems to have worked. :smiley: