Please make Roblox close when using your OS's close button

This is incredibly annoying - ever since Roblox introduced the new Pause Menu, using your Operating Systems close window button now opens this menu:

This is incredibly annoying and even frustrating at times - I use the close button on my OS so I can easily leave a game and hop back into studio (which previously only took two clicks). Now to do this I have to press the exit button, move my mouse to the middle of my screen and press “Leave Roblox” before I can go back into studio. I understand that you want to push the new in-app game browser, but please just make that only accessible through the pause menu leave button (or even just add a “Don’t Show Again” option to the already existing menu).

53 Likes

Fun fact! There used to be a checkbox to never show that prompt again, but Roblox removed it purposely. It’s a completely nonsensical decision and the option should be brought back.

26 Likes

Thanks for this feedback! The team is aware and looking into it.

13 Likes

In a browser when you close the client you usually have the Roblox website open behind it. This does not happen in the windows app because it’s all self contained.

My understanding is that this is a convenience function. Users want to press X to leave a Roblox game and more often than not they want to continue to browse Roblox for games, not completely close the application. It’s more hassle to open the menu and fumble for the leave game button.

Not sure if it behaves this way already, but maybe clicking the X again should close the application outright after showing this window.

7 Likes

This feature is extremely annoying, hopefully they remove it.

5 Likes

Ok, I don’t know if this is newly added… I’m now again seeing this never show that prompt again. However the OK button is highlighted. I just figured out f11 can help a headache, now I fear checking this will close the interface leaving the highlighted selection active…

1 Like

If you check the box, nothing will happen until you either attempt to close it again or click the home button. I clicked the home button with the box checked and it still recognized that I had the box checked and I am therefore not seeing the prompt anymore. And yes they just re-added it today.

@Tom_atoes A checkbox to never show the prompt again has just been added today. Other threads regarding this issue have already been marked as solved and the bug report is already locked.

1 Like

You pressed home button instead of the operating system’s close button?

I clicked the “back to home” button on the prompt with the “don’t show again” box checked. Since then I’ve not seen the prompt again even after closing Roblox.

1 Like

A “Do not show again” has been added again thankfully.

image

4 Likes

Ok, here is the prompt with the Don’t Show Again checked. Now, I want to Close Rolbox and not see this prompt again… is that what will happen if I press the Close Roblox button? (not the Back to Home button) I’m on PC…

If you click either button, with the box checked, you will not see the prompt again.

It seems to have made a return recently.

1 Like

It has gone away from when I use the top right close box after pressing F11 for windowed to exit a game. Little bit better… Still have to use f11 to exit a game. Just so I don’t get redirected. But for now this works.

The top right close button on the Roblox player (and any keys used to close the window) should not take you to the home page unlike the “leave” button. It should instead close right away if you previously closed Roblox with the “don’t show again” box checked. Are you having to press F11 instead of the close button or Alt + F4 to immediately close Roblox?

I’m on PC and the only way to just close Roblox is to use f11 then the upper right close box on the window. Just leaving the game normally will open the home page. Before, it would just go back to where I was when I launched the game. The redirect is more than a hassle while programming. I guess the phones need it… I don’t know. I guess Roblox can’t even tell what the user is on themselves. Likewise, I have problems with that myself. Using the “don’t show again” and close (the left button) worked to not show the prompt. But I am still forced to use f11 & window close or alt + f4. I can’t use the games leave option without going to the home page. Honestly more than hate this and while programming adds a hassle to deal with constantly with every test.

Are you sure you can’t click the top right close button without pressing any key?

Have you also tried pressing Alt + F4 without pressing F11?

And yes, the “leave” button on the game menu and disconnection prompt are intended to take you to the home page.

Edit: Oh is this because you always use full screen?