(Possible Solutions) Invisible Unions, Disappears when separated? "Corrupted Unions"

I’ve looked online for some solutions but have come up dry time and time again. As I work on my project I’ve used many unions and blender models within the small area I’ve built this far. However, after some time through testing and just walking the map to make sure there are no building errors I’ve come across the “Corrupt Union” bug. I’ve read that they are stored online which causes them to bug out to where I’d have to recreate the model from scratch. So, I’ve saved the models into my inventory and tried to replace them using the toolbox. The unions still wont load. Now my confusion is this… The same model that is within a model did not receive the same bug? (Picture Reference Below)

You can see that the crates near the building still have the metal banding where as the crates near the water do not.

The only solution I see is creating a “Mass” model and putting it in server storage just so that the unions will never corrupt and I can copy my commonly used assets from there. But this seems like more of a hassle than anything. I’m open to ideas.

Possible Solutions:

  • Highlight parts (Connected or not) and export them as an .obj file. Then import them through a MeshPart. To get proper placement, I copied the position of the corrupted union and pasted it into the new MeshPart’s position.
  • Save your game often and in multiple locations. Example: For me, I build my models on a base plate, then save them through Roblox and place them into the main map. Also, completed models I put them in server storage that way if the asset through Roblox doesn’t work as that was also the issue here. I can update the asset through server storage.

my friend use to export the union as .obj and import it back in studio when this happens with him. ( i never tried it tho ).

I tried to export the union as an object file but an error occurred and didn’t allow it. Instead I exported the entire model but now I don’t get the same look that I intend for it. The only solution I can think of now is copying the unions from the unaffected models however this is still not a permanent solution to the issue and it could very well still reoccur.

1 Like

You should export parts separately. like first the brown part then the grey part.


So, instead of creating unions within the studio, instead export them as object files and then import and place them?

1 Like

I suggest to use meshparts instead of unions, they’re much better than unions and they don’t fail to load as much as unions do.

You can also try to check the recent autosave files to find the unions that became corrupt, copy them and paste into the place you’re currently working on.

Hope this helps!

1 Like

To prevent this from happening, model in an unpublished place and import the models into the published place you want to put it in, ive never gotten corrupted unions saving just to my device, even with the most complex of unions