Premium 450 Not Available on Desktop

Device Info

  • User agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/ Safari/537.36
  • Platform Type: PC
  • Device Type: Computer

Unable to purchase Premium 450 on the Roblox website.

Tried it with all browser extensions disabled.

However, Premium 450 option is available on the mobile app but the app wouldn’t allow me to use my Roblox credit balance.

Expected behavior

Able to click the Premium 450 option.

Page URL:


bruh premium is broken now, just stick with the 2200 one…

1 Like

I have 450, 1000, 2200 but not the rest:

Possibly region related?

I don’t believe there was any option more than 2200 (unless I’m mistaken?)


There is no Premium subscriptions bigger than the 2,200/month, so you got all which are available. “Not available” just seems to be a placeholder for something that doesn’t exist.


I can’t be region related, otherwise you’ll have the same outcome as me or the other way around. This seems to affect each account in a different way. Some are able to buy Premium 450 but not the rest, while some are able to purchase only Premium 1000.

1 Like

I seem to have different results across different accounts. My main one can only buy the $20 premium, one of my alts can only buy $10 premium, and another one can buy everything up to 20$, so it can’t be region related. This is all quite weird. It’s probably just broken like BowlORice said.


For me, the only option that appears is the 1,000/month option.

1 Like

I have 2.2K option only :confused:

1 Like

For me the issue occurs differently on different account, despite with the same currency
and both is on desktop:

Account 1:

On this account only premium 450 is avalible

Account 2:

On this account only premium 1000 is avalible

And even more weirdly, it seems to let me purchase any level of premium by changing ap=481 to 480, 481, 482 in
or /upgrades/payment?ap=481
once you get onto the payment page.

Update: according to the post below, it appears to work


This URL trick seems to be working. I finished my purchase using Roblox credit and boom, I have premium now. You need to be on the payment portal already for it to work. This proves that it’s truly a bug from the Premium page, since you’re able to purchase all of them on the mobile app anyway. I contacted Roblox support and they can only answer,

The Robux subscription packages you are requesting are currently unavailable. We apologize for the inconvenience.

They don’t even mention that they’re at least trying to solve the problem. Is this problem really unfixable?


I don’t know if this is always the case but in addition to some tiers missing, the “other” payment option is also missing (aka. The ability to use amazon pay)

again, seems to bring back the option by changing url from paymentMethod=XsollaCreditDebitCards to:



Godsend! I tried changing the 480, 481 portion of the URL before but that was before I had selected a payment option. After selecting a payment option it lets me. Further, I think that limiting the premium purchase options is intentional but buying it through the URL is an unintentional bug I’m assuming as seem to intend on limiting premium purchase options as of now reading their response after I submitted a customer support ticket.


Seems like if you want to use paypal you can use:

Bumping to get an update. My premium was just canceled, and some acknowledgement of this issue from Roblox would be great so I can resubscribe to the tier I want.

1 Like

Your premium was auto-cancelled?
I don’t think that’s supposed to happen unless you have insufficient credit…I think in the past it would not even be auto-canceled if you got banned.

Yeah, I believe the canceling could have had to do something with my card, but due to this bug I can’t resubscribe to the tier I had without paying through some workaround.

1 Like

I found that it’s intentional until the end of June

Roblox is runnning some package availability tests, so this is intentional for now :wink:

Source: I made a private message to @Bug-Support and Focia19 told me that


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.