Pressing dot on Numpad doesn't work for In-Game Chat

Go into any game and press . (dot, period) on the numpad to observe the bug

Happens in every game all of the time
(also happens in Studio)

do you also have this problem?

  • Yes
  • No

0 voters


Can’t reproduce.

Perhaps num lock is turned off for you?

if you watch the video you’ll see that my numpad lights are on

I did but I can’t repro the bug

I tried too and it worked just fine for me.

This problem occurs for me on my Razer Cynosa Chroma keyboard regardless of num lock enabled or not. (No macros attached to any of my keys.)

Can you submit a link to the game in which you checked it? . This is probably a mistake in the game itself and not in the Roblox because I, like 70% of voters, are all right.

Is the keyboard working correctly?

it could be my computer idk but it’s been like this since forever in every game and in studio

Well. Then, in this case, try to check the relevance of the drivers for the USB ports. Perhaps they are satisfied or not relevant.

Have you tried reinstalling Roblox and Studio or Reboot your PC ?

If it doesn’t occur on everyone’s device then you should do due diligence of adding details on your setup.

1 Like

@buildthomas I definitely agree with that, I’d probably get to that when I’m free.

Thanks for notifying.

@Deezater, Yes I restart my Pc, I even re-installed windows and this still happens.


This is happening to me right now. I am in-game and my num-pad keys are not working. [EDIT] I restarted my PC and it is back to normal.

1 Like

I am seeing this…on an HP laptop. Some observations:

  • This bug does not happen in Studio for me.
    (No decimal point in Non-NumLock mode–Not treated as Del in that mode either.)
  • When not in chat, in the Desktop app, I observe that it’s getting
    Enum.KeyCode.Delete when it should be getting
    Enum.KeyCode.KeypadPeriod, which it does in Studio on the same computer.
    Clearly an indication of what’s wrong.
  • It doesn’t matter what state NumLock is in on the Desktop app.
    (On the Desktop app non-NumLock mode is ignored in chat, yet in either state, delete is sent.)
  • If I hammer away on the key in chat once in ~10 (varies widely) a decimal point will show up.
  • The problem does not exist on the Windows Store / UWP app.
  • As I reported long ago, the Desktop and UWP apps are inconsistent w/ respect to NumLock behavior
    (Arrow/Non-NumLock mode is ignored for chat on the Desktop app, but in the UWP app it is not.)
1 Like

The numpad works fine for me while using in-game chat. I have no problem with this situation. Maybe it’s more of an issue with the keyboard?

How about the Numpad-period–That’s what this is about? I would say that it is possible, however it’s
still a bug because there are different behaviors in Studio vs. the Desktop app in terms of the keycode
seen on the same computer, therefore there is a programming difference which causes the problem.

Closing in favor of a better written version of the report: UserInputService not reflecting Keypad inputs properly (SHIFT and KeypadPeriod)