Previously purchased Bundles do not appear in Preset Costumes Tab

Page URL: Roblox
Impact: Moderate
Frequency: Constantly
Date First Experienced:
Date Last Experienced:

Reproduction Steps:
Browser: Google Chrome, not using an special plugins

This has been a bug since the avatar page was last updated. Bundles that I purchased before the update do not show up under my preset costumes tab I am still able to use all the items that come with the bundles. This includes the, Hats, faces, and body parts of the bundles are still under their respective pages are present, however I must manually equip each body part manually.

Expected Behavior:
I would expect that the Preset Costumes Tab should be able to display all the bundles and packages that I own on ROBLOX rather than some.

Actual Behavior:
This is a screenshot of the end the costumes tab:


After the “man package”, I have several other bundles/packages that are supposed to show up, however they do not appear

This is the avatar page scrolled down under Body > Torso. This picture is to show that I do have the parts to the bundles I purchased, but again the full packages do not show up in the preset costumes tab:

In the first image you can see the Party Executive bundle followed by only the man bundle. In this second image of the torsos you can see the Party Executive torso followed by multiple other torsos that are part of the said bundles that don’t show up. My avatar page has been like this since 2018.

The only workaround to this issue is to manually select the body parts associated with the bundle/package. This can be a nuisance at times, as some bundles have up to 8 body parts that I have to manually equip onto my character.


Thank you for bringing attention to this. I contacted roblox support about this a few times over the past few years and didn’t come up with any working solutions. It’s a nuisance to equip everything one by one and would love to see this bug addressed.


Not like 100000% related, might be idk.

When RTHRO was released in 2018, the animations were slowly rolled out, I bought every animation (from the RTHRO animation package) one by one.

I never got the actual RTHRO animation bundle. Tried contacting roblox support, answered but nothing. Very vague.

This is still a problem in my account and I tried asking them to remove the animation from my account but they couldn’t.

It seems as if, you get the RTHRO animation bundle, you get a “outfit” item with it, but for me, that was not the case, because I didn’t get the actual bundle, I got the animations one by one.

For some reason, it resulted in it saying I own it, when I don’t.


This has been an issue since the release of the re-modeled character page. I’ve even made a YouTube video trying to explain further to Roblox in a support ticket. Hopefully this gets addressed or resolved sooner than later!


The Rthro Animation Package doesn’t show up under Preset Costumes for me as well. It says I own the bundle on the item page and I have the animations. Not sure if it’s of the same or similar issue. If the rthro animation bundle came out after the avatar page update then it might be a different but similar issue for that item specifically. Everything else I bought after the avatar page update shows up, including other animation packs.

1 Like

Just saw this little update when checking out my Costumes. Wonder if this is related?

1 Like

Thanks for the report! We’ve filed a ticket to our internal database and we’ll follow up when we have an update for you.


Even with this slight re-design of the avatar page, the said bundles are still missing. I know this was said it’s being filed in a ticket but it’s been like this since 2018.

1 Like

Hello! Does this issue occur anymore for any of you???

Yeah this issue still occurs for me


Still an issue for me unfortunately

I own a few costumes / packages as body parts but they don’t appear in costumes, been a problem for a few years.


I am also getting this issue. Now that so many free bundles have come out I got them all and my old ones aren’t showing up. Even some of the new bundles I got are not showing up. The same goes for the new animated faces or “Styles”.


Ok, I found a solution. You have to open up the Roblox app instead of trying to do it on the website. It’s annoying because it often says “No items found” at random times, but you will be able to see all of your bundles and styles.


I believe the issue you are having is being rate limited loading items on the avatar page. If things are loading too fast it’ll just stop showing items you own and they won’t show up on the page. It’s real annoying when you have a lot of items and you can’t see them. The apps are usually better at loading everything in but the website limits you.

Can’t believe this thread got a reply after 2 years. This original bug this thread is about is still an issue and I still can’t see the bundles I purchased pre-2018 even when I’m not being limited or use the app. They just aren’t there.


Not sure why you’re getting that issue. Every bundle shows up for me as long as I am using the app. Even the old bundles.

I am getting the same error, I described this in a New Topic

1 Like

I am currently dealing with this issue. I can’t view all of my bundles when in the Avatar customizer and when I try to go past the first 3 pages of my bundles and heads in my Inventory, it repeats them under new numbers (ex. 1,2,3 will be displayed for 4,5,6). It can do that forever.

For some reason, this doesn’t seem to affect accessories or any other normal assets, but specifically the dynamic stuff. Since my old, non-dynamic bundles (I like to call them packages) are in the same category, I can’t use them either.

What’s the point of buying stuff if you can’t even use it? It’s disappointing.


How is this from 2021 and it still hasn’t been fixed. The same problem happens with head styles.

1 Like

This bug report is for a different issue. Recent replies to this topic are probably looking for this.


Thank you. I’ll retract it and check out the appropriate thread!

Although I do hope this issue can be looked at as well, not a good look to have this open after 2 years.