Problems with animating weapons?

Okay, so i saw this post and decided to try it, now im no animator but i just wanted to test it, you see, how i weld my weapons to the player is using RightGrip thing (i forgot xd) of the player. Now it works, but it doesn’t for this, there is scripts you have to do while making this to make it work. And when playing the animation it doesn’t play correctly, now looking through the comments of the post is that its because the tool is welded to the player’s hands and more (i tested it and it worked) if i make it into an actual tool that isn’t welded, it works. But if i weld it, it doesn’t. How do i fix this? Is there another way of welding the weapon without causing any problems?


I already have tried this a little while ago and I was successful however when I played the animation it worked fine except when the animation stopped it went to the player’s torso so it’s not really reliable unless someone states a fix for that, however as it says in the topic you need to weld it with that plugin he provided in his topic and you cannot use regular welds.

1 Like

I used the welds in his topic but what i meant is welding the swords to the players hands permanently, since tools only go to the hands when you equip it.

I saw this

Which was @Headstackk replying to someone who had a similar problem to me.
I did try it on a tool and it worked perfectly fine, exact same script and no changes (except the accessory was a tool.)
I think the reason this is happening is because I’m using “RightGripAttachment” which is welding the weapon to the player’s hands.
Here is a screenshot of the explorer:
Thanks again!

Oh hey, correct me if I’m wrong but that’s it right? The cause of the error is because of the weld I use from this post.
I cant really give a good example of my error right now but its like this post you replied to.
Its exactly like it, I don’t know if his cause of error is because of him welding the weapon to the player’s hands, but either way, its a very similar thing and actually removing the weld (aka using a tool instead)
makes the animation work.

Yes, the weld from that post is likely the problem.

Is there a fix you can reccomend me? I tried removing the weld before starting the animation and it doesn’t work. So any fixes you can reccomend? Since i don’t wanna use tools, since im pretty sure it could work if i use a tool (i just gotta redo the scripts.)

(I don’t like using tools since i wanna make the weapon permanently on the player’s hands.)