"Property "Animator.EvaluationThrottled" is not currently enabled" when printing a Model

I’ve noticed that if I print my model (ex: print(Model)) after it has some animations loaded into it, it seems that under specific conditions it will just spit out this error:

Must be a recent issue because I’ve never had this error pop up before

7 Likes

I also ran into this a couple of days ago when animating the character when using a tool,

When the player equips the tool, they are given a movement animation, then when the tool is activated (used) an action animation is used, once the action animation is finished the movement animation is resumed… This particular error shows up (with the exact number of outputs as the OP) when the movement animation is resumed.

This doesn’t really affect any of the functionality as everything seems to be working fine even though this shows up in the output.

1 Like

This reminds me of every other time that Roblox for whatever reason adds a new feature to the engine (usable now) but intentionally disables it and spams errors if you try to use it. (This happened to me with ZoomToExtents and IKControls in the past!)

For now, the only way to stop these useless error messages is to set the AnimatorIsThrottledPropertyEnabled DFFlag to true, which requires Roblox Studio Mod Manager or a ClientSettings(?) modification.


They should really come up with a new “log message type” for disabled features like this so I can hide them easily; It makes it harder to spot legitimate errors while my experience is loading.

15 Likes

Thanks for the report! I filed a ticket in our internal database.

9 Likes

Problem went away for a while, then Studio had an update today and it’s back.

3 Likes

It’s still happening to me, so i guess it isn’t fixed yet

2 Likes

When are they going to fix this, I’m getting tired of seeing these errors that I can’t fix.

1 Like

FWIW, this error does seem to happen when printing a Humanoid into the Output window, as indicated by the subject of the original poster. If you can avoid outputting the Humanoid variable then the error goes away.

I was using code like this to keep track of when damage was happening to a humanoid “hum”.

print("Damage", hum, hum.Health)

Changing the print to use hum.DisplayName causes the “Animator.EvaluationThrottled” error to go away.

print("Damage", hum.DisplayName, hum.Health)

Not a fix for the underlying problem, but a workaround that helps clean up the Output window.

3 Likes

I also get this error spam when seating in a seat.

2 Likes

An error occurs when printing Humanoid when the character sits down on the seat. It is in this line of code:

-- print(seat.Occupant)

1 Like

thank you for your help I guess

This bug is still present in local server. I have not tested if it still does it in the actual experience server hosted by AWS.

5 Likes

I’m still having this issue. I don’t think it has been fixed yet.

1 Like

Issue is also occuring for me too.

1 Like

The error appears to be around again, but this time it causes lag when triggered.

It also happens to me any fix ?

I just had the exact same error a few minutes ago. I just removed the line where I printed the Animator and it worked.

Yes thank you this doesnt make any sense but it works i guess lol

I just got this error recently too while working with Animator Instances. I was not printing the Animator instance anywhere, though. However, after removing a print statement which was printing out the client Camera instance, the error went away. Very odd.

just asking is the bug fixed? cuz im getting the same bug