Public Group Game not showing on Group Page

So I made a new group, and created a group game that’s set to public. Also, made sure to set group games to show within group settings. I check back a few hours later and it’s still not showing, nor are any other games I create and set to public.

EDIT: One day later I’ve tried this again with a new group that I just created only to have the exact same issue

Referring to this - Games not showing up on new group page

I’m aware this has been a bug before, and solved countless times before so I’m assuming it’s just resurfaced.

EDIT: Multiple friends have glanced with either not seeing the games as well or only 1 out of the multiple active games showing as shown by a screenshot from a friend shown below ~

as of 9/4/2019 - 12:30 AM PST… Issue seems to of resolved its self with all active games showing up (4/4) after about a day / two. Feel like this should still be looked into as a bug regardless.

1 Like

This topic was automatically closed after 1 minute. New replies are no longer allowed.