Games not showing up on new group page

Currently, with the new group page, many group games are refusing to show up on the group. Some do, but our main ones do not.

This is the game that we want to show up: https://www.roblox.com/games/2605826950/BANK-Coruscant-Underworld-ALPHA and this is the group https://www.roblox.com/groups/2742631/The-Galactic-Republic#!/about

This has been impacting player levels because new players simply have no way to get to the game, other than ads.

Group games is checked to be visible on the group page.

9 Likes

4 posts were merged into an existing topic: Off-topic and bump posts

This bug report is about games not showing up on the Groups profile page. Do not discuss or rant about the new Group profile layout here.

There is currently a bug where some of my active games are not displaying on the group page. Currently, my main game is not displaying, while another game will display on the group page just fine. Both games have the same exact settings on their game and start place configurations. I expect that my main game which has been having a steady income to physically appear on the group page.

This bug occurs daily and I can not fix it. I have tried making the game private, then public again, but still, it fails to appear. Shutting down the place does not resolve the problem either.

image
image

The game experiencing the issue:

This bug has been noticeable by my partner and I ever since the new group update. I would like to know as soon as possible when this bug is fixed. I imagine some players in the group rely on group game links to play the game.

3 Likes

I’d double check to make sure your group settings are correct so the games are visible. group

1 Like

It is marked, otherwise my game “Prarie” wouldn’t have been able to show up in the first place.

I’ve tried checking, and unchecking that box multiple times. There is nothing I can do to make my main game appear on the group page.

3 Likes

This affects me too. I cannot find a way to get my game to show in the Games area.

3 Likes

I have this issue too. One of my group games won’t disappear.

and it’s really bothering me :disappointed_relieved:

3 Likes

I’m having the same issue, I recently created a group with me and a friend of mines so that we both can make games together, I made it yesterday and we’re creating a game but it won’t show.

I’ve selected “Group games are visible on the group home page” but it still doesn’t display, funny how the bug appears and bothers me right when I make a group. :confused:

2 Likes

We are looking into this issue.

3 Likes

It has been 8 days and I can still confirm I have the issue.

I have done everything in my power to solve it.
I’ve turned on/off group game display, removed all the gamepasses from the game, turned off Team Create, reverted it back to the original place.

NOTHING WORKS :sob:

Even though my issue is a game not disappearing, I’m likely dealing with the same bug

1 Like

Any updates?!
Still having this problem… its been months

3 Likes

Problem is still persisting.

2 Likes

My games started appearing on the group page today!

2 Likes

This should be fixed. Let us know if it’s not fixed for you.

2 Likes

I’m having the same problem. This place originally when made (around 3 days ago), appeared on my Group’s game page, but has now disappeared. I do have the “Group games are visible on the group home page” setting ticked.
Could I please get some help?
Here is the link to my group: https://www.roblox.com/groups/4803355/Ganz-Games#!/about


The group page only shows public games. The SS Development game you’ve sent a screenshot with is private.

1 Like

I started having the problem not long ago and was redirected here, a private game showed up on the group page and a public game is hidden in the group. But when I checked the group page when I was logged out, everything was fine.

Here is the problem I see:


Group Page -Notice that there are 2 games, “Plane Games” is not suppose to show up, and “GWS Headquarters” is suppose to show up.
image
Game Page -As you can see, “GWS Headquarters” is public and “Plane Games” is only a place and not a game.

Place Page -As you can see here, “Plane Games” is private and doesn’t have a game to parent to.