Random UI Fragment Appearing after Run Testing (New UI)

This is happening to me regardless of what I am doing. Just play & stop, boom. Very annoying.

1 Like

It happened to me too. I fixed it by disabling a faulty plugin. Disable all your plugins and try again, also restarting Studio after the plugins being disabled should help.

But I use my plugins :cry:

I’ve already disabled all the non-essential ones, but the issue still happens

It doesn’t happen if I play as a player tho. Only if I do a server play

Try disabling each of your plugin one-by-one, and check if one of them still make the grey box appear. If it appears after disabling ALL of your plugins, restart Studio. If you find the problematic one you should enable it only when you beed to use it, and report the issue to the creator or something.

Are there any updates on this?

This is an incredibly annoying issue and really makes testing on the server not practical

1 Like

Hi @CaptinLetus, we have just fixed this. Please restart your Studio and see if you are still having the issue. Please let us know.

1 Like

I think this is related but hopefully fixed in the change @robloxtuesdays0611 mentioned:

Occasionally when opening a place, the worldspace fragment will not be docked and open in a separate window

Almost every time when doing a local server test, the worldspace fragment will open in a separate window

In both cases, the worldspace fragment is not draggable and cannot be redocked manually

Edit:
Woohoo! Appears to be fixed in 0.549.05490632 release

Edit:
Apparently it doesn’t completely fix the issue, but it is better

this bug is caused by the plugin “Hoarcekat”

this new studio stuff is so buggy its really getting on my nerves now

randomly seperates the game window aswell
image

1 Like

This is also an issue which has been getting on my nerves for atleast 3 weeks now. I am on Studio Version 0.549.0.5490632 (64bit). The Update that supposedly “fixes” that issue (it doesnt)


Roblox, Please fix this, is a serious issue within Studio and is also annoying as heck as you have to constantly manually re-adjust the Toolbox and/or other WidgetGuis

I can confirm this is happening aswell. In most cases when I have 2 instances open, the viewport just completely disappears until I close that window

Yeah, as cool as the new UI is, it’s an absolute joke and simply too unstable. Would love to know how they decided to push it out. I’m using Studio Mod Manager for the time being to use the version prior to it. What’s interesting is that I am now also getting problems with widgets that get stuck on the screen and cannot be closed in the older version, ever since the new UI was released, albeit extremely rarely as opposed to very frequently with the new one.

Can confirm, the update did seem to help a bit, but the issue still remains. It makes local server testing unusable.

Hi @jgrimm1, can you please list some of the steps that you do during your server testing process that result in the issues you’re having? Also, what is the resolution and scaling of your display?

I am still having the same issue

I noticed that, but for me it goes away.

I’ve noticed that completely wiping Studio from my system (uninstalling via Add or remove programs in Windows Settings, removing any left over Studio files in AppData/Local/Roblox/Versions, removing these folders:

  • [folder with a user id as its name, in my case it was named 500634351]
  • ClientSettings
  • InstalledPlugins
  • placeIDEState

also removing these files:

  • GlobalBasicSettings_13.xml
  • GlobalBasicSettings_13_Studio.xml
  • GlobalSettings_13.xml

and removing Studio’s registry key
(Computer\HKEY_CURRENT_USER\SOFTWARE\Roblox\RobloxStudio)) seems to have fixed all of the issues mentioned above, however it does come at the cost of losing your settings, widget layout and probably some other things

Looks like this glitched plugin screen also can’t be properly closed when studio closed:

It seems to be whenever I try to start a local server test with any number of players.
My screen resolution is 1440p and scaling is 100% on Windows.

Local play tests seem to be fine.

1 Like

I tried reinstalling studio but that didnt fix it. However when I deleted the regedit key, it was fixed.