Realism — Make your games feel more immersive!

I kind of just gave up on caring because I don’t think anyone’s going to die on a hill for footstep sounds that can be easily reproduced. I’ll go out of my way to make my own if I must, but I honestly don’t think it’s worth getting worried over.


Which sword you using this video? @Maximum_ADHD

I don’t think realism adds any custom animations, I assume the sword in that video is animated just to show that realism behaves properly when playing custom animations

1 Like

what game is being played in this video? I’d love to play it

When using streaming enabled, Realism does not work.

Edit: Realism works but as of now you have to die one time for it to kick in.

why is arm are looking weird sometime?


Hello. I’ve been using realism for quite a while for my first person game, and it’s really good! However, I found that when I weld a cap to the head of the character after the character dies places the cap inside the camera for some reason. Here’s a video of welding the cap before and after dying:

I assume this is because this function:

is called only once, when the FpsCamera (client module script) is started. And the RunService connection that makes the first person more smooth unbinds after the camera subject (Humanoid) is destroyed.
I tried to call :OnRotationTypeChanged() every time new humanoid is added but it did nothing.

Please let me know if I’m doing something wrong or if I can fix this problem!

1 Like

Same issue as above, this is really annoying

Does it work when you zoom out and then zoom back in? I was having similar issues, and for some reason, zooming out fixes it. Quite annoying.

There appears to be a large issue with this Realism module, not sure if you still support it though I’ve been using this module for years and just now this started to become an issue.

Some character models (which aren’t the default fat roblox avatar) have strange elbow bending

1 Like

I made sure to also check the GitHub and use the latest version, which still has the issue. Here’s a quick video I took for proof:

1 Like

After further inspection, it appears that your arms bend at a certain angle, as if you point your camera straight at your character, it’ll switch back to the default idle without the bent arms.

1 Like

Hmm, seems like a pretty big issue. In the mean time I’m no-longer using the module, it’s been something that I’ve absolutely loved for all this time! (years)

But in the end I might just remove the bending part and keep all the footstep sounds and things like that (since I really do like that feature)

Other than that! Hoping there’s a fix

My game has first person lock. You can’t zoom out, so that’d be great if there was a solution

Disable retargeting in your game. This fixed it for me.

Would be great if someone made a solution to the first person welded accessories problem, it’s making us go crazy lol

Guys apparently my head get chopped when I zoom in: :scream:

Normal Head


Anyway *cough cough nice resources I would definitely use my epic *cough cough Ctrl C key :+1:

This would be because Roblox will not render shadows for parts that are transparent, there is no solution to this other than a few rendering-bugs that work half of the time, so basically, there is no solution to this.

Guy the model is great thank until my character start bashing his head onto the wall, the air like a rock metal enjoyer :crazy_face: :love_you_gesture: (I don’t know if this caused by any script but clearly I didn’t even mention the camera on any of my script lol)

It got worse I think he need to go to a mental hospital real quick

The filming are very poor sorry for the low fps

1 Like

There is a fix for it, and it’s just setting the ‘LocalTransparencyModifier’ of the head to zero every update, although that wouldn’t look quite good, as your accessories wouldn’t show up.