Really Weird Animation Playback

I’ve made some animations using the editor with inverse kinematics enabled. They look fine when played back in the animation editor. The feet stay about the ground and the character moves coherently. Here’s what they look like in the editor. https://www.youtube.com/watch?v=o8oaKRFJ5C4

However, when I play them back in game, the animations look really wacky. Here’s a video showing what I mean: https://www.youtube.com/watch?v=yOumOHzMiTw
When the boss walks around his feet should stay planted on the ground and his sword he drags behind him should as well.
Then there’s the animation rig that I have set up to play the swing animation over and over. His legs drop beneath the floor and his animation just looks wacky compared to the original. Also one of his legs is jutting away at an odd angle and not letting any animations get applied to it.

In this video the NPCs have the default animation script in them, but I get the same results when I disable it.

3 Likes

So I know this has been an issue as of recently first posted here. I believe this is an issue with the Roblox animation plugin or playback system. So there for as I encouraged before report it but for you seeing as there have been topics about it in the past see if there already is a report instead of accidentally making a duplicate topic. I don’t think there’s much you can do other than that or asking @salcret personally if he found a fix.

Maybe I should just remake the animations but in blender this time. Kind of a headache, but it seems there’s no other option. I think the problem lies with the editor itself and how it exports the animations. They seem glitchy when I view them on the website using the extension “Making Roblox Better”.


So to me, it just seems consistent that the animations are messed up once they get exported from the editor.
1 Like

I didn’t find a solution to my problem, so I instead worked around it by completely redesigning the system I was creating.

In this case, I don’t think there’s an easy way to solve the problem. Maybe consider posting this as a bug report.

1 Like