Red Screen When Play is Clicked

Hello! So I made my game, it’s all done and ready to be tested for one final time before publishing. I click the play button in studio and am hit by a big red screen. (picture below) Anyways I had got this screen before and last time I just reinstalled studio, waited and it went away but now it doesn’t seem to want to budge.

Ive had some people saying could be a virus but I don’t think so because it went away last time, I only download trustworthy plugins/models and I tried in a blank world and I got the same red screen.

How can I get rid of it? What can I do to prevent this in the future? What is causing this?

(Not sure if this is the right category but im having trouble with playing my game which is game design soooooo.)

Edit: Tried an alt account and got same red screen.

UPDATE: Roblox Studio just hates me. My mom walks in my room so I can show her the issue to see if she can help and it works. She walks out I go back into my world press play and it has broken again. ._.


Have you tried to re-install roblox studio?

She tried already


Yes i was clarifying because she said last time not this time:

Edit: on second read yeah I guess she tried that… thanks for pointing it out :slight_smile:


Is this screenshot from the baseplate attempt? If so, what is in replicatedstorage?

Edit: just realized that if it fixed from reinstalling studio and came back and happens on empty baseplate then it must be a plugin… to test disable all plugins thru the plugin manager and see if happens. If it doesn’t, re-enable them one at a time testing each and seeing which one does it.


Show the output?
id just try going through and disabling plugins one by one. remember that you have to restart studio AND create a new place after disabling a plugin.

I reinstalled studio one more time just to see and still no luck. I disabled all the plugins following your steps and I still see the red screen.

Tried, no luck. :confused: I have no idea how it was fixed so fast last time and now im stuck.

Please show your expanded Lighting properties.

Only happens when you play? not when you are in studio, but during test mode?

Is this on one experience, or all of them
If it is on one, can you try comparing the differences with another?

All games sadly. Hoping just one game then I could just make a new map but unfortunately it is all.

Yep only when I play. When building or scripting everything works great and my screen is fine. Lemme bring up lighting for you although I don’t think that is what is wrong.

Under the lighting tab there is:

  • Atmosphere
  • Sky
  • Bloom (Intensity 1, Size 24, Threshold 2)
  • Dept of Rays (Far Intensity 0.1, Focus 0.05, Near Intenisyt, 0.75, In FocusRadius 30)
  • Sun Rays (Intensity 0.01, Spread 0.1)

When the game starts, click into StarterGUI and see if any screenGUI is created… also do the same in lighting after the game starts… you’re looking for something that adds itself upon the game starting… UI or Lighting.

Nope sorry, still didn’t work. I’ve reached out to Roblox support and they are working me through some other ways to fix it. Thank you guys for your help though.

Video of new world being opened:

1 Like

Good luck! and if it was something unusual please come back here and post it, you got me so curious!

When I contacted them they said over and over again I should just uninstall and reinstall studio even when I told them that didnt work when I tried it. It was like I was talking to a brick, the person who was trying to help me didnt provide anything helpful and just linked articles that I had already read and that didnt work. So much for getting help, I may just not be able to use studio now which really really sucks since most of my time was spent doing build commissions. Very unhappy with their support team right now.

Are you running windows? . . . . . . .

Edit: in Studio Settings under Render and then Graphics Mode, what do you have it set on?

Im running mac. In-studio settings graphic mode is set to automatic.

1 Like

And my mac is macOS high sierra 10.13.8.

It won’t hurt to hit the reset settings button down in the lower left in case something changed in there …

Edit: also, have you tried to enter Full Screen Mode when it starts and see if this has any effect at all?