Release 447 broke camera controls

Since today’s release 447, I’m seeing all kinds of reports regarding broken camera controls.


One of the bugs with the Camera’s CameraType property set to Watch. When you right-click to orbit your camera, your camera doesn’t stop rotating (even after you let go of your mouse button), until your mouse cursor changes position.

This is happening on at least PCs and mobiles.

CameraType.Watch is the only thing I was able to reproduce and to some extent “understand”, but I’ve seen reports from other people that they’re not able to zoom in their camera, or that when they zoom in/out, it keeps zooming in/out, even though they’re no longer scrolling their mouse.

Some players are not able to play games because of camera issues. Would it be possible to revert these camera changes until they’re improved?


Here’s @FastKnight401 response that pretty much describes one of these issues

And other:

Have you also seen issues relating to the camera? Reply with your experiences.

28 Likes

I was about to make a post about this issue. It only happens in games where the scroll-wheel doesn’t zoom in or out, it just pans the camera. I was playing trade hangout about 1 hour ago when I first noticed this bug. It is very annoying, and the past hour I have been having serious trouble playing some games at all.
Edit I forgot to mention when I zoom in using the “I” key I can’t zoom back out using the “O” key.

6 Likes

The camera also bobs around for me, even in Classic mode, which is supposed to prevent any automatic movement. This effectively ruins the ability to play any game that requires precision.

5 Likes

Would be awesome to get repro levels for these. I can’t seem to reproduce the watch camera issue.

Logged the arrow key speed issue, will be fixed.

3 Likes

Can confirm this is happening in my team’s game: Airport Tycoon. When the CameraType property is set to Attach, and you simply rotate the camera slightly on Mobile - the camera will never stop rotating. This CameraType has also caused problems with the zoom property, where on PC the players’ camera is stuck and they are unable to zoom in/out.

I can also confirm that I have issues with every single game when trying to zoom out with the Apple Magic Mouse (w/ horizontal scroll feature), my camera will rotate forever.

4 Likes

This is a major issue, at least on mobile. I was testing my game on mobile and this occurred. Would a video help? Unfortunately, this is really hard to repro, it seems to randomly happen for me.

Edit: I also get stuck in first person when playtest. Working on videos right now.

Edit 2: I was able to get both issues on video.

Videos

First person issue:
https://drive.google.com/file/d/11AMyIZo_SWplAAFkfhSO6yz8eJGD_isx/view?usp=drivesdk
Scrolling issue:
https://drive.google.com/file/d/11C1K4DlXSNOmUolsq5mBeaLlu_933_83/view?usp=drivesdk

Meant to reply to @subcritical, not OP, sorry.

3 Likes

Here are the steps that should be taken to see the issue with CameraType.Watch:

  • Create a new place or open an existing one
  • Press F5 to play test
  • In Explorer, find the Camera object, go into its properties, and change the CameraType to Watch
  • Orbit your camera without letting go of your mouse (notice it not stopping)
  • Let go of your right mouse button without moving your mouse (notice it still not stopping)
  • Move your mouse cursor (notice it stop)

Edit: For some reason, I’m not able to replicate it anymore. Did someone revert these camera changes?

3 Likes

This bug is more occurrent on Mobile. CameraType with Watch, Orbital and Attach all have this infinite camera rotation issue.

1 Like

I was able to get these issues on video. Hopefully staff can resolve this.

2 Likes

Thank you for reporting this issue. I thought that my game was the only one experiencing this issue and I panicked pretty badly without having checked the DevForum first.

My game features a third person camera implementation which relies on BaseCamera for the firearms, however it seems that the UserCameraInputRefactor FastFlag has completely blocked calls to BaseCamera which likewise also broke my game. I tried implementing an alternative to no avail - this incident may cost me some players and heavy delays.

Just one call to BaseCamera rendered the game unplayable because no one could control their cameras. It would be stuck at a certain position after spawning in.

Are we not supposed to directly interact with PlayerModule modules anymore and if so, why was that API available to begin with? If we still can but the way we can interact with the modules changed, what was to be the expected alternative while working with the camera and why was there no heads up?

My game had to be closed for several hours because of this, and was up for more hours in a broken state. Both me, my team and my community were completely confused up until a few minutes ago.

9 Likes

Roblox seems to have done some reverts.

Anyone else feels like the camera issues mentioned above are gone now, or is it just me?

5 Likes

Yep, the flag was turned off. I just checked my game and the camera works again.

I really hope that they address this update more cautiously before turning the flag back on. This is a change that needs an announcement. If they tinker with the camera and then flip the flag back on, my game will break again. I need to know what the alternative is and need time to switch to that new method. API changes should be accompanied with an announcement.

I’m trying not to butcher the PlayerModule right now in case I do something wrong. I knew I should’ve kept a forked version of the module pre-flag, but I try not to fork if I can help it so I can’t just go back and use that as a patch. The only thing left for me now is to hope that flag doesn’t get turned on again.

8 Likes

Doesn’t seem to be fixed on mobile, I just checked again. I think most of the issues have been resolved, but the mobile issues are not. This could be why games such as adopt me have lost players, they have a mobile heavy userbase.

3 Likes

Are you in any old servers? The flag is also off for the AndroidApp and the iOSApp, so new servers should also follow in suit with the camera not being broken.

3 Likes

Can confirm the first person mobile glitch is still live, I just tested in a brand new private server of my game.

4 Likes

I’m in my own showcase, it shouldn’t be an old server but let me reset it.

3 Likes

Have any other camera related flags been turned off? I could not reproduce the issue in the second video, instead camera just got stuck to the humanoid even after it was teleported.

1 Like

From what I’ve checked over, no, most of those flags have not been touched at minimum for a month, I think one even fetched for a year. The following FFlags are involved with the PlayerModule if you want to have a look and see their status:

  • UserMakeThumbstickDynamic (ControlModule)
  • UserNavigationClickToMoveSkipPassedWaypoints (ClickToMoveController)
  • UserCameraToggle (CameraModule, ClassicCamera, CameraUtils, BaseCamera)
  • UserRemoveTheCameraApi (CameraModule)
  • UserCameraInputRefactor (OrbitalCamera, ClassicCamera, CameraInput, BaseCamera, LegacyCamera)
  • UserFixZoomInZoomOutDiscrepancy (BaseCamera)
  • UserFixGamepadCameraTracking (BaseCamera)

Can browse through FFlag Watcher or the function UserSettings():IsUserFeatureEnabled(“FFLAG_NAME”).

3 Likes

I occasionally seen the camera go into some sort of orbiting where scrolling would just go up or down in a circular motion of your character, you’d be unable to zoom out or in.

I am not sure if this bug has been reported separately here.

1 Like

Should be reverted (may have to force-restart your mobile app to refresh). We’ll make some fixes and try again next week.

5 Likes