Release Notes for 571

Something has completely broken physics of humanoids trying to walk on moving surfaces. You frequently get stuck in place, pushed back, and jitter around. This has been occurring in numerous games that feature players walking on large vehicles such as ships, trains, planes, etc.


I have been experiencing the same problem as everyone above me has mentioned. I made a bug report for it which you can find here. Please check if my findings match all of yours. If anyone has any additional information or found other causes please respond to the bug report I made.


It’s also introducing some weird camera jerking artifacts when playing animations, we have a melee combat system and it suddenly started twitching the camera on each punch.


Ditto. This happens to my mobile and xbox players the most, and even some pc players, but after ~10 minutes or upon start up the game completely crashes.
Seems to have only happened starting when this update came out. (We didn’t update when this happened.)
I’ve been losing my mind over this.


Yeah my average session time went from 18 minutes to 8, lol.
But since its fixed it went back up.


Oh wow, it does seem to be fixed. I guess they did it without a client update. Did roblox ever acknowledge this bug? I didn’t see any posts about it from roblox.

nevermind, i found one mention on this thread:


Oh god, the snap to grid increment actually rounds what you put in now…
I put in 0.0625 (standard increment I use a ton), and it didn’t just display as 0.063… the increment itself became 0.063… if I move a part it moves in increments of 0.063, not 0.0625.

1 Like

Someone’s looking into this, not intentional.


OH THANK GOD. Good to know someone is looking into it at least.

I think it’s done that for a while now. If I typed in that number, it always was rounded up to 0.063 (and 0.03125 would become 0.031).

In the past, did it only visually round the numbers, actually using the full number when moving parts around?

Yeah. Also this bug is still not fixed yet, hopefully it gets fixed soon. Haven’t built in studio for 6 days as I’m still waiting on this.

The grid snap input will be fixed in the May 3rd Studio release. Unfortunately the fix didn’t quite make it into this week’s release.

As a bonus though the general behavior of the box has been overhauled along with the fix: Entering zero disables snapping instead of changing the increment, and the grid snap is no longer bounded, you’ll be able to enter as small a value as you want and have it work.

1 Like

The bug got fixed yesterday, thankfully.

This has been asked before in a bug post but when can we get the UI snapping fixed after this update seemingly broke it?

Yeah, I had to disable the fix last week due to it breaking snapping in the Transform tool.

Next week there will be a new fix up which has been split up in such a way that we’ll definitely be able to keep it on. Sorry it has taken so long to get a fix permanently on for this.


Alr, that’s good news, thanks for responding.

Some good news at long last, Thank you for informing us.

Is there any updates on this? Any estimated timeline for fix?

1 Like

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.