Restart servers for updates is unreliable / doesn't restart all servers

Our game, Play for UGC, releases a new free UGC everyday and ever since we started using the new “Restart servers for updates” function, it sometimes does not update all servers, ending up the ugc not being available in all servers. I have heard players mentioning this a few times now but have only been able to gain evidence today. Upon releasing the update today & using the “Restart servers for updates” I was notified by a small amount of players that they don’t see the ugc (server running old version) so I restarted again and their server remained unaffected. To clarify, this only happens to a small amount of servers.

How the shop looks like in latest version:

How the shop looked like in their server (server didn’t update and remained in old version):

Shutting down all servers “fixes” / avoids this issue

Page URL:


Confirming this is also happening for the game I work on. “Restart servers for updates” is not working at all a child/linked place within the experience. This is preventing me from hotswapping place-specific changes that I can’t justify shutting down the entire experience for.

1 Like

Thank you for surfacing this issue! For those running into it, please clarify the following information to help me investigate further.

  • Was the “Restart servers for updates” button clicked on the experience (universe) page, or for a particular place that is part of the experience?
  • Please also provide the following: universeID, placeID, a rough time window of when the restart was attempted, and the latest place version at that time.
  • We only have 1 place in the experience. I am unsure on which page I clicked it but I think it was on the universe page
  • Universe ID: 5214046401, Place ID: 15129197851
  • First restart was done a few minutes after 2:55 PM CET (Unix time: 1712840100) and 2nd one at around 5:50 PM CET (Unix time: 1712850600). After it didn’t affect that server we were testing on I did a full shutdown at 8:45 PM CET (Unix time: 1712861100)
  • First restart I published and restarted version 3458 and 2nd time being confused I published and restarted again 3459. Full shutdown was with version 3459

Unix time stamp converter

1 Like

I do have the same issue for the last 16 hours the following buttons only work on 10% of the servers,

  • Migrate to latest servers
  • Shut down all servers

I do have a game with a big community and people are asking me why the game isn’t update and i am not able to do anything about it!

If tried the migrate and shutdown like 10x and most of the servers are still running on the old version which sucks, i wanted to launch a proper weekend update hype which is ruined now!

This is the game: [New Cars]Realistic Car Driving™ - Roblox

1 Like

Happened again today - I am sure I did use the restart on the universe page, this first happened 35min ago. First restart version 3478, 2nd time I went for a shutdown with version 3480 (fixed some bugs and this did put all servers on latest version). All of the other info is the same as in my previous message

That’s weird as shutdown all servers fixes the issue for me. If you find yourself having to shutdown all servers again, consider adding a soft shutdown system (if you haven’t already) which teleports all players to a different game and back upon shutdown. Example: Softshutdown V2

I put one account in each place on my game, around an hour ago, right after publishing at 9:46AM CST, i tried every method of getting the server to shut down, and the servers never migrated to update or shut down. However, it seems a few of my servers did, as my player count went from 2900 to 2300 in a few minutes.

Here are the methods i used:

  1. “Shut down all servers” on the experience page
  2. “Migrate to the latest update” on the experience page
  3. “Restart servers for updates” on each of the places on the creator hub.

The published version at the time for my starter place was:
4044 April 12, 2024 at 9:46 AM

My universe is:
Other places in universe:
16298762026, 16983511790

I am still sitting in the same servers over an hour later and they have not updated.
Please fix asap :frowning:

1 Like

Thanks for the information everyone. I’m looking at this actively and will provide an update as soon as I make some progress with the investigation!


Update: I am continuing to investigate the problem and don’t have a root cause yet. However, I’ve made some changes to our backend that might help alleviate the issue. Please try updating again and add the same information as requested above if you notice the issue happening after 04/12 12pm PDT.


Ok, i rebooted and this time witnessed an old server get updated. We looked around at 30 servers and couldnt see any old ones

1 Like

Just updated our game and couldn’t find any non updated servers, thank you!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.