Reuploaded Asset-Privacy Compliant Audios Failing to Load

Roblox is currently investigating an issue with the Marketplace. Assets may appear unavailable and audio may no longer play as expected.

Experienced a similar issue. Some audios were being loaded but all audio TimeLengths were set to 0 (this only happened in-game and not in Studio). This impacted an audio playlist, as something like wait(audio.TimeLength) before continuing would now just skip the audio.

Players in my game are also experiencing no audio despite using new audios owned by the same entity as the game. Very frustrating that we were given this shake up only for it to break in the first place.

It’s assuring at least that we did the right thing and are just waiting for a fix.


I have given my game access to many of the audios but they don’t work in game

1 Like

This issue seems to be affecting EVERY audio at this time. Nothing works.

1 Like

Thank you for the reports. We are aware of the issue and are working on it!


Hey, the issue just started occurring to me in the last hour as well

any updates?


@lego555444 Can you please confirm this is fixed? Thanks!

1 Like

I’m also still having this problem. I’ve tried setting the permissions through the website and by clicking on the error message, and while the website says that the experience has access to the asset, the same error pops in the console and the sound doesn’t play.

1 Like

My game used a footstep sound module, most if not all sounds fail to load, werent those supposed to stay usable if below the 6s mark? The plugin showed everything with a blue check. But now i keep getting the “Universe doesnt have permissions for Sound Asset…” error message.

This bug is becoming increasingly CRITICAL to fix; the audio to my game is crucial to adding to the atmosphere and I’ve been getting endless comments about certain maps music not loading. I’ve actually noticed a dip in players because of this bug.

The longer this bug lasts, the longer my experience (and therefore revenue) is interrupted.

I’ve made my audience aware but it not a great feeling having to be the bearer of bad news for something I had already prepared for.

Do we have an ETA for a fix yet @Kero?

1 Like

Oh hey, other people are experiencing this too?
This weird bug is getting pretty annoying, but I do have my experience to share too.
I am making a baseball bat weapon for my game and I only started experiencing this issue when I uploaded the sound of the baseball bat being swung. (see below)

And about the supposed patch of the bug that was announced by the staff, it was kind of fixed as you can still hear the sounds ingame rather than studio (probably just a me thing)
Anyways, just tried to share my own experience with this bug. Hope it gets fixed soon!

Hi @Crazyblox! I’m sorry to hear about it. Can you provide details about what steps have you done to grant the audio permission universe and what didn’t work? Thanks!

Can you elaborate on the steps to reproduce the issue? Did you click on the Action Item to grant audio permission to the universe? After that, do you still see the same error in the output window?

Hi @Hotpes! Sorry to hear about the issue! Do you own the footstep sound? Did you try to grant the audio permission to the game? If there are still errors in the output window in Studio, can you share the game universe id and asset id? Thanks!

Hey! Heres my answers to this question:

To elaborate, all I ever did was upload a baseball bat being swung onto my account, and the game in question is also owned by me. This bug really confused me at first so I’m not really sure how to explain it more than just “audio don’t work even though its owned by me and i put it in a place thats also owned by me”

I did click on the action item thing before I put my input on the situation, the same error popped up.

EDIT / EXTRA: This bug spontaneously got worse as literally all of my audios that were uploaded by me / my main development group do not work anymore. This doesn’t affect the SFX I took from the library, which are by other users and not the official Roblox account.

Hi @DrEgguin ! Can you share the universe id with me? Feel free to DM me. Thanks!

Edit: Note that once the Universe ID is added to the list that this does not apply until hitting Save afterwards. APanda helped me resolve my issue, thank you.

The audio is owned by the group Crazyblox Games.
The game using the audio is also owned by the group Crazyblox Games.

To try and troubleshoot I gave the audios used in my game specific access permissions to see if it would budge, but unfortunately nothing has solved it.

Would be interesting to think that because the audios are pure re-uploads their hash got confirmed and bypassed moderation instantly and now it’s triggering a false positive perhaps. Hope I’ve helped.

A note:
@Crazyblox solved the issue by clicking on Save button on audio configure webpage after adding the new universe id there.
@Hotpes solved the issue by using public sound effects.
@DokuDako solved the issue by disabling friend only option for the place. We identified the friend only issue is a bug. We will fix it asap.


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.