Granting audio access to game doesn't work

Reproduction Steps
Currently if you try to give access to audio owned by a different entity it will not work properly in game

Expected Behavior
I expect audio to work in game after granting access to them

Actual Behavior

I have given my game access to many of the audios but they don’t work in game

Issue Area: Engine
Issue Type: Other
Impact: Critical
Frequency: Constantly
Date First Experienced: 2022-03-23 00:03:00 (+07:00)
Date Last Experienced: 2022-03-23 00:03:00 (+07:00)


This is already being looked into, it’s a Marketplace disruption.

Also for your feature request on which I cannot reply (check if asset failed to load): use pcall.

thanks for the information.

I saw the banner but I’m unsure if they are also aware of this issue as “Marketplace disruption” could mean a lot of things and I’d like to ease my mind with certainty that they are made aware of this issue and fix it asap.

have you tried this before suggesting it? pcall doesn’t work that way

On second thought, sounds have a loaded property.

But even then the output will print an error, so it would only help with the scripting part.

Nevermind the pcall part, I can’t test right now as I’m going to sleep.

I’ll bookmark this for tomorrow.

Hello! Thanks for the report! A fix for this is being worked on.


Hey devs,

We are working to fix a critical issue where servers are unable to load private audio even when it was uploaded on the same account and the experience has the correct permissions.

To determine whether a particular audio of yours is affected, visit the Configure Item page for that audio and check whether the Universe ID of your experience is listed. If it is listed and the audio is still not loading in that experience, you are being affected by this bug. It should be automatically resolved once our fix goes live.

We appreciate your patience and will post again when the issue is resolved!


Thank you very much! I cannot wait :grin:

Hi there-I am experiencing the same thing BUT it has been happening since you guys released the Audio Discovery plugin. I am unable to grant access, and it shows in the plugin. This makes me think it is not related to whatever bug spawned today.

Please see this post for screenshots.

I posted about this exact thing right when it started just around 3-4 hours ago. They’ll find a fix for it, hopefully.

Again, it has been happening for me about a week, so I don’t think this issue is relating to the current marketplace issues.

1 Like

Can anyone help we with this: all the info from Roblox seemed to indicate that assets uploaded by groups would have access to all universes owned by the group.

My understanding was the permission system was just to explicitly grant access to audio that isn’t owned by the group.

Did I get this wrong? Do we still have to update permissions to grant access to universes within a group even if the audio is owned by the group?

1 Like

No, the permission system is only for if the audio isn’t uploaded to the ‘correct’ group / user.

I pray, oh how I pray, that you’re right and the copy on this message is incorrect:


EDIT: I didn’t mean to reply to you @lexandstuff, sorry!!

Unknown if this is out there but I’ve observed a few things while troubleshooting this problem myself in various circumstances. These tests were performed on audios that have no specific permissions, they are unchanged from before the update was pushed out.

The following list is what I’ve found, anything in bold are things I believe are unintentional.

If a user joins a place they own:

  • Audios they uploaded work fine
  • Private audios still work

If a visitor joins a place they don’t own:

  • Audios the place owner uploaded work fine
  • Private audios don’t work
  • Audios the visitor uploaded work fine*

If a user tests a place they own in studio:

  • Audios the place owner uploaded don’t work
  • Private audios don’t work

If a user joins a place owned by a group that they own:

  • Audios the group owner uploaded work fine
  • Private audios don’t work

If a user joins a place owned by a group they don’t own:

  • Audios the group owner uploaded don’t work
  • Private audios don’t work
  • Visitor audios work fine*

If a group owner joins a group place in studio

  • Audios the group owner uploaded don’t work (This is fine, but it’s inconsistent with how it works in-game)
  • Private audios don’t work

*Visitor audios work completely fine if I use them in a boombox, It’s almost like they play locally and no one else can hear them (I’ve tested it).

I know a few of the behaviors can easily be fixed by messing around with permissions, but it’s just some weird behavior I’ve observed while messing around with this update. Hope I can see some of these inconsistencies fixed.


Hmm, seems like asset privacy compliance is being verified on the client instead of the server. (or something went wrong during replication)

1 Like

Any updates? Would be nice if this could be fixed soon, I can’t start fixing my stuff until it’s out.

1 Like

Please fix this and update us quickly. It’s getting ridiculous and we’re losing a LOT of productivity


The staff replied in another topic. This was in the last 5 minutes.

This is happening for me with audio that was uploaded by the Roblox account as well (see: Ice Cream Cone Lick Attempt 2 - Roblox
as well as this APM track: Courtly Dance Main light - Roblox)

I am super disappointed. I did everything in my power to prepare, and followed the instructions to the T.
Audio discovery tool says that I’m allowed to use every sound asset in my game, including those uploaded by Roblox.

This thread seems to only talk about assets uploaded by users. Can I get confirmation as to whether I’m supposed to have permissions to use audio uploaded by the Roblox account itself, given it’s marked as OK by audio discovery?

1 Like

Yes, Roblox audios are allowed to be used.