Reuploaded Asset-Privacy Compliant Audios Failing to Load

Reproduction Steps
In-game, the f9 debug console shows failed to load audios despite them being re uploaded to the group many days prior.

Game link:

Recent changes:

Expected Behavior
We expected the audios to stay functional today given that all the old audios were re uploaded to the game’s group and approved days prior.

Actual Behavior
Audios are failing to load despite being the audio discovery tool plugin giving them a blue check mark:

Issue Area: Engine
Issue Type: Other
Impact: Very High
Frequency: Constantly
Date First Experienced: 2022-03-22 10:03:00 (-05:00)
A private message is associated with this bug report


This is very much impacting my team as well.

All assets have been reuploaded under our group and several audios still fail to load despite being approved.


Same for me. Trying to re-upload the sounds seems like a waste of the free audio limit as they still may not work.

Audios that I just uploaded very recently are not being loaded.

1 Like

Hello. Thanks for the report. A fix for this issue is being worked on.


SFX is also not working (audios with less than 6 seconds).


I can confirm that our team is experiencing this as well, despite ensuring that every sound was marked as “OK” using the tools provided.

1 Like

We just ran into this with the Innovation Inc Thermal Power Plant. The game is owned by the user AnimeRiceFarmer, as opposed to a group, and the audios were uploaded by them a couple of days ago.

Example audio we have that was uploaded by AnimeRiceFarmer:

Output when attempting to play in Studio:

[ACTION ITEM] Universe doesn’t have permissions for Sound asset: 9147949621. Click here to grant Universe permission to asset.

RoBeats had the same issue - workaround for now was to manually set permissions for audios affected.

Roblox is currently investigating an issue with the Marketplace. Assets may appear unavailable and audio may no longer play as expected.

Experienced a similar issue. Some audios were being loaded but all audio TimeLengths were set to 0 (this only happened in-game and not in Studio). This impacted an audio playlist, as something like wait(audio.TimeLength) before continuing would now just skip the audio.

Players in my game are also experiencing no audio despite using new audios owned by the same entity as the game. Very frustrating that we were given this shake up only for it to break in the first place.

It’s assuring at least that we did the right thing and are just waiting for a fix.


I have given my game access to many of the audios but they don’t work in game

1 Like

This issue seems to be affecting EVERY audio at this time. Nothing works.

1 Like

Thank you for the reports. We are aware of the issue and are working on it!


Hey, the issue just started occurring to me in the last hour as well

any updates?


@lego555444 Can you please confirm this is fixed? Thanks!

1 Like

I’m also still having this problem. I’ve tried setting the permissions through the website and by clicking on the error message, and while the website says that the experience has access to the asset, the same error pops in the console and the sound doesn’t play.

1 Like

My game used a footstep sound module, most if not all sounds fail to load, werent those supposed to stay usable if below the 6s mark? The plugin showed everything with a blue check. But now i keep getting the “Universe doesnt have permissions for Sound Asset…” error message.

This bug is becoming increasingly CRITICAL to fix; the audio to my game is crucial to adding to the atmosphere and I’ve been getting endless comments about certain maps music not loading. I’ve actually noticed a dip in players because of this bug.

The longer this bug lasts, the longer my experience (and therefore revenue) is interrupted.

I’ve made my audience aware but it not a great feeling having to be the bearer of bad news for something I had already prepared for.

Do we have an ETA for a fix yet @Kero?

1 Like

Oh hey, other people are experiencing this too?
This weird bug is getting pretty annoying, but I do have my experience to share too.
I am making a baseball bat weapon for my game and I only started experiencing this issue when I uploaded the sound of the baseball bat being swung. (see below)

And about the supposed patch of the bug that was announced by the staff, it was kind of fixed as you can still hear the sounds ingame rather than studio (probably just a me thing)
Anyways, just tried to share my own experience with this bug. Hope it gets fixed soon!