Rig doesn't work properly

Hey! Sorry if the title is vague, but I had a problem similar to this post, and I fixed it by anchoring the HumanoidRootPart. That made it so it can be rotated and moved correctly in the animation editor, however it won’t work in-game because the HumanoidRootPart has to be unanchored to be able to walk/move. If you need a gif of it or an image I will send some, and if you have more questions ask!


A few questions:

Have you solved this issue?

Are there any welds inside any of the rig’s parts?

And could you provide an example of the broken rig in RBXM format?

1 Like

hey! the issue has not been solved. Yes there are welds inside the rig, a few actually. I didn’t think they would break the rig tho because I used rig edit lite plugin to make the rig. I tried to remove the welds, but it didn’t fix it. Here’s the rig: snowman.rbxm (55.8 KB)

Hey there, me again. I managed to Solve the issue.

For whatever reason, resizing the HumanoidRootPart to a size larger than the Torso fixed it, i dont know why it does this though. prob just something to do with mass.

I apologize for the long response wait, i got busy with something else

1 Like

thanks! i just managed to fix the issue. I had to make the root part bigger and change the way i was handling animations. (I was using the default roblox animate script, so had to move animations to the AI script I was using) I’m sorry for taking forever to reply btw oof :frowning:

1 Like