Character torso not rotating in editor

I’ve been sitting here for around 30 minutes trying to figure out what’s happening to make it do this. I properly rigged it, but the torso isn’t moving and the grid below is. I’m very confused and frustrated.
Everything is working properly except for the torso and I made sure nothing is anchored.


Sorry for the bump but I’m still experiencing this issue. If anybody knows why please share. Thanks!

1 Like

In my experience with custom rigs, I have a couple solutions that may or may not help…

  1. Try anchoring JUST the torso in the animation editor and see if that helps at all
  2. Try making a root part, and just attach it to the torso
    Hope this helps :slight_smile:

I already have a HumanoidRootPart in it and as I look at it again I realize that seems to be the part moving instead of the torso.

So now my issue is my Torso is pulling my HumanoidRootPart instead of itself

1 Like

Alright. Try just anchoring the torso / root part or whatever you use as your base and see if that works

1 Like

I just anchored my HumanoidRootPart because the anchoring my torso didn’t help and now the torso is pulling the entire model

Can you show me the hierarchy?

Something may have occurred when moving it.

It’s working properly now! Thanks for the help!

1 Like

It stopped working again. I’m so frustrated with this. I’ll send you pictures of the rig in a bit

Mine Worked all i had to do was unanchor the Troso and anChor the Humanoid Root part

I found a more practical solution than anchoring the RootPart! Just set the RootPriority property of the HumanoidRootPart to 10, worked for me

1 Like

If anyone still reads this, you can try changing the animation priority.