Roblox framerate low on good pc

So uh, this never happened before, but lately my roblox has been stuttery and choppy. Only now it happens, never happened before. I can run other games well such as csgo.
specs:
nvidia 1660ti
i7 intel core

These are good specs, and can run most games fine. Would I use my gpu or my cpu to run roblox. I’ve tried both, and the cpu seems a little less stuttery, but i want to remove all lag. Even my old pc could run roblox smooth.

2 Likes

I don’t think you should’ve posted this here, but anyways try changing graphical settings from studio
1, Open the roblox studio and from the FILE Menu select Studio Settings
2, Select Rendering and try every option in General > Graphics Mode until one works the best

1 Like

Ngl, i also have a extremely fast pc. Bt it just is very laggy! In the end you should choose another topic. you can use That discussion topic.

1 Like

Oops, sorry. accidentally posted it here, Im just so used to posting things in this topic.

4 Likes

Automatic, and Vulcan seem to have the least lag, but still lag. Any fix?

1 Like

I do agree with this, I’m not sure how much roblox uses gpu, I have a 2070 super and an i7 and I can run Call of duty at almost max graphics with 120 frames.
But then I play Quantum Science games and I run them at 45 fps.

2 Likes

Maybe roblox is not running on your nvidia GPU? Are you using windows 10?

1 Like

When i run on my gpu, it still lags, but when i run it on cpu, doesn’t lag as much. :man_shrugging:

1 Like

Okay but are you using windows 10?

1 Like

Yeah, I am using windows 10. Why?

1 Like

Okay try this
1, Search for “Graphics settings” in the start menu and open it.
2, Search for “Roblox” in the start menu and select “Open file location”.
3, if you get a folder that only has roblox and some other icons, right click on the selected file and select “open file location” again.
4, Copy the address of that folder from explorer.
5, Go to graphics settings and set the dropdown menu value to “Desktop apps”.
6, Click “Browse” then add the roblox executable “RobloxPlayerBeta”.
7, Set it’s setting to high performance.

1 Like

i still experience some lag in medieval rp, and arsenal.

1 Like

I don’t know how to help you bro, see youtube or contact roblox support

1 Like

Like before a few weeks ago it would run smootly only recently. Also in the nvidia control centeer would i set roblox to run on gpu or cpu?

1 Like

It’s a little complicated I cannot explain here, see a tutorial on youtube

1 Like

A note, i’d have 500 fps one second, and then every 20 seconds i would drop down to 30 frames, and people woudl warp around the map for a sec. Really annohying, and never happened before, ty for the help though.

1 Like

Ping causes lag, check you ping

Yeah, but the thing is, it has only happened recently. Before I could easily run any game on roblox smooth. I haven’t done anything to roblox settings, jsut stopped playing for a month. When I come back, my game is hella laggy, and I use 5g wifi, never above 100 ping most of the time.

I have my frames drop a lot when my processor is not using turbo boost and is on 2.6GHz, however if i let my computer decide when to use turbo boost, as soon as roblox opens my cpu overclocks to 4.5GHz, although the fans get loud it doesn’t lag as much, however I assume its from all the parts and detail in most games

Yeah, even with my turbo mode on and everything still lags, like when i look at the dump, I’m getting like 500 frames, but every like 10 seconds it drops to like 10-20-30-40, then goes back to 500 which is really getting annoying, never happened before.